Bug 58413 - ViewResultsTree : Request HTTP Renderer does not show correctly parameters that contain &
Summary: ViewResultsTree : Request HTTP Renderer does not show correctly parameters th...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.13
Hardware: All All
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 58954 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-15 20:31 UTC by Philippe Mouawad
Modified: 2016-02-01 21:24 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2015-09-15 20:31:51 UTC
For a request like this:
GET http://localhost:8081/?login=toto1&pwd=Welcome%261

Welcome%261 being the encoding of Welcome&1

HTTP Renderer will show in parameters table:
1	
pwd	Welcome
login	toto1

This is due to this line:
https://github.com/apache/jmeter/blob/trunk/src/protocol/http/org/apache/jmeter/protocol/http/visualizers/RequestViewHTTP.java#L194



This case was reported here:
http://stackoverflow.com/questions/32567037/jmeter-why-jmeter-ignores-from-csv/
Comment 1 Philippe Mouawad 2016-02-01 21:12:07 UTC
*** Bug 58954 has been marked as a duplicate of this bug. ***
Comment 2 Philippe Mouawad 2016-02-01 21:12:32 UTC
 benoit.wiart@gmail.com 2016-02-01 20:57:29 UTC

the problem comes from the url decode done before the split of the parameters and not after.
This patch also implements a less hacky solution for bugs 52491 and 54055
See test case for detail

[reply] [−] Comment 1 benoit.wiart@gmail.com 2016-02-01 20:58:35 UTC

PR https://github.com/apache/jmeter/pull/98
Comment 3 Philippe Mouawad 2016-02-01 21:24:14 UTC
Date: Mon Feb  1 21:22:33 2016
New Revision: 1728009

URL: http://svn.apache.org/viewvc?rev=1728009&view=rev
Log:
Bug 58413 - ViewResultsTree : Request HTTP Renderer does not show correctly parameters that contain &
Bug 58954 - Request view http does not correctly display http parameter if it contains '&'.
#resolve #98
Bugzilla Id: 58413

Added:
    jmeter/trunk/test/src/org/apache/jmeter/protocol/http/visualizers/
    jmeter/trunk/test/src/org/apache/jmeter/protocol/http/visualizers/RequestViewHTTPTest.java   (with props)
Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/visualizers/RequestViewHTTP.java
    jmeter/trunk/xdocs/changes.xml