Bug 58439 - [PATCH] Rename private FormulaShifter.adjustPtgDueToShiftMove to adjustPtgDueToSheetMove
Summary: [PATCH] Rename private FormulaShifter.adjustPtgDueToShiftMove to adjustPtgDue...
Alias: None
Product: POI
Classification: Unclassified
Component: SS Common (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 enhancement (vote)
Target Milestone: ---
Assignee: POI Developers List
Depends on:
Blocks: 58348
  Show dependency tree
Reported: 2015-09-21 20:49 UTC by Javen O'Neal
Modified: 2015-10-23 09:01 UTC (History)
0 users

rename adjustPtgDueToShiftMode to adjustPtgDueToSheetMove (929 bytes, patch)
2015-09-21 20:49 UTC, Javen O'Neal
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Javen O'Neal 2015-09-21 20:49:13 UTC
Created attachment 33123 [details]
rename adjustPtgDueToShiftMode to adjustPtgDueToSheetMove

In FormulaShifter.java, the private method adjustPtgDueToShiftMove adjusts the sheet field of a Ref3DPtg after a sheet has been moved. This was added in r1142219 as a fix for bug 48294.

To differentiate a sheet move from a row move, I think a more appropriate name for this method is adjustPtgDueToSheetMove. This also aligns the name with the public static createForSheetShift method.

Because this method is private, it shouldn't affect any other files or existing code.
Comment 1 Javen O'Neal 2015-10-23 09:01:36 UTC
Implemented in r1710147 <https://svn.apache.org/viewvc?view=revision&revision=1710147>.

Deployed to trunk.