Bug 58446 - Excel document needs repair after simply opening and saving document
Summary: Excel document needs repair after simply opening and saving document
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.10-FINAL
Hardware: PC All
: P2 normal with 4 votes (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-22 13:54 UTC by kcarter
Modified: 2015-11-02 20:28 UTC (History)
0 users



Attachments
minimal program to cause issue. (803 bytes, text/plain)
2015-09-22 13:54 UTC, kcarter
Details
minimal excel document to create issue. (9.62 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-09-22 13:54 UTC, kcarter
Details
resulting excel document after running through program (7.45 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-09-22 13:55 UTC, kcarter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kcarter 2015-09-22 13:54:06 UTC
Created attachment 33133 [details]
minimal program to cause issue.

I have been able to create a simple program that when fed a certain excel document when it comes out the other end and is opened by Excel Excel prompts "We found a problem with some content in <filename> Do you want us to try and recover as much as we can? If you trust this workbook click yes" Clicking yes always leads to success and has a repaired record of: "Repaired Records: Table from /xl/tables/table1.xml part (Table)"

I am not entirely sure what it is about this particular spreadsheet that is the issue, something in the table that it contains because if I remove it there is no issues and if I copy the table to another spreadsheet and run the program it is also corrupted. 

I have tried this on 3-10-FINAL-20140208 (where the issue was found), 3-11-20141221, 3-12-20150511, and 3.13-beta1-20150723 with all the same result.  

Please find attached the minimal program and the minimal excel document to reproduce this issue. 

I really hope I am just doing something wrong but this issue has concerned a crucial user of my software which is affecting his trust in the software.

Dependencies include: 
 dom4j-1.6.1.jar, xmlbeans-2.3.0.jar, poi-ooxml-3-10-final-20140208, poi-ooxml-schemas-3.10-FINAL-20140208, 3-10-FINAL-20140208
Comment 1 kcarter 2015-09-22 13:54:45 UTC
Created attachment 33134 [details]
minimal excel document to create issue.
Comment 2 kcarter 2015-09-22 13:55:23 UTC
Created attachment 33135 [details]
resulting excel document after running through program
Comment 3 David North 2015-10-29 11:12:16 UTC
I can't reproduce this on trunk using Excel 2013.

Please can you re-try with 3.13, and if you still have a problem, confirm which version of Excel you are using?
Comment 4 kcarter 2015-11-02 20:28:00 UTC
Didn't work for me on the beta but did on the released 3.13 it looks like. Thank you for the info.