Bug 58619 - org.apache.xmlbeans.impl.values.XmlValueDisconnectedException while accessing the Excel sheet for the second time
Summary: org.apache.xmlbeans.impl.values.XmlValueDisconnectedException while accessing...
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.10-FINAL
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-17 06:55 UTC by Mahesh
Modified: 2015-11-30 05:25 UTC (History)
0 users



Attachments
Crash summary (47.98 KB, image/jpeg)
2015-11-17 06:55 UTC, Mahesh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mahesh 2015-11-17 06:55:13 UTC
Created attachment 33281 [details]
Crash summary

Following Exception being displayed while writing values to the Excel sheet



org.apache.xmlbeans.impl.values.XmlValueDisconnectedException
	at org.apache.xmlbeans.impl.values.XmlObjectBase.check_orphaned(XmlObjectBase.java:1213)
	at org.apache.xmlbeans.impl.values.XmlObjectBase.newCursor(XmlObjectBase.java:243)
	at org.apache.xmlbeans.impl.values.XmlComplexContentImpl.arraySetterHelper(XmlComplexContentImpl.java:1073)
	at org.openxmlformats.schemas.spreadsheetml.x2006.main.impl.CTDefinedNamesImpl.setDefinedNameArray(Unknown Source)
	at org.apache.poi.xssf.usermodel.XSSFWorkbook.saveNamedRanges(XSSFWorkbook.java:1288)
	at org.apache.poi.xssf.usermodel.XSSFWorkbook.commit(XSSFWorkbook.java:1309)
	at org.apache.poi.POIXMLDocumentPart.onSave(POIXMLDocumentPart.java:322)
	at org.apache.poi.POIXMLDocument.write(POIXMLDocument.java:179)
	at functionLibrary.Utilities.putCellData(Utilities.java:279)
	at com.ancestrystage.driver.DriverClass.main(DriverClass.java:203)
org.apache.xmlbeans.impl.values.XmlValueDisconnectedException
	at org.apache.xmlbeans.impl.values.XmlObjectBase.check_orphaned(XmlObjectBase.java:1213)
	at org.apache.xmlbeans.impl.values.XmlObjectBase.newCursor(XmlObjectBase.java:243)
	at org.apache.xmlbeans.impl.values.XmlComplexContentImpl.arraySetterHelper(XmlComplexContentImpl.java:1073)
	at org.openxmlformats.schemas.spreadsheetml.x2006.main.impl.CTDefinedNamesImpl.setDefinedNameArray(Unknown Source)
	at org.apache.poi.xssf.usermodel.XSSFWorkbook.saveNamedRanges(XSSFWorkbook.java:1288)
	at org.apache.poi.xssf.usermodel.XSSFWorkbook.commit(XSSFWorkbook.java:1309)
	at org.apache.poi.POIXMLDocumentPart.onSave(POIXMLDocumentPart.java:322)
	at org.apache.poi.POIXMLDocument.write(POIXMLDocument.java:179)
	at functionLibrary.Utilities.putCellData(Utilities.java:279)
	at com.ancestrystage.driver.DriverClass.main(DriverClass.java:204)
org.apache.xmlbeans.impl.values.XmlValueDisconnectedException
	at org.apache.xmlbeans.impl.values.XmlObjectBase.check_orphaned(XmlObjectBase.java:1213)
	at org.apache.xmlbeans.impl.values.XmlObjectBase.newCursor(XmlObjectBase.java:243)
	at org.apache.xmlbeans.impl.values.XmlComplexContentImpl.arraySetterHelper(XmlComplexContentImpl.java:1073)
	at org.openxmlformats.schemas.spreadsheetml.x2006.main.impl.CTDefinedNamesImpl.setDefinedNameArray(Unknown Source)
	at org.apache.poi.xssf.usermodel.XSSFWorkbook.saveNamedRanges(XSSFWorkbook.java:1288)
	at org.apache.poi.xssf.usermodel.XSSFWorkbook.commit(XSSFWorkbook.java:1309)
	at org.apache.poi.POIXMLDocumentPart.onSave(POIXMLDocumentPart.java:322)
	at org.apache.poi.POIXMLDocument.write(POIXMLDocument.java:179)
	at functionLibrary.Utilities.putCellData(Utilities.java:279)
	at com.ancestrystage.driver.DriverClass.main(DriverClass.java:205)
Comment 1 Nick Burch 2015-11-17 12:23:46 UTC
Can you retry with a more recent release? IIRC, there have been some fixes in this area in the time since 3.10 came out
Comment 2 Dominik Stadler 2015-11-29 23:09:06 UTC
No response for some time and this is likely fixed in newer release, setting to WORKSFORME for now, please reopen with a sample code and files if you can still reproduce this with the latest version of POI (currently 3.13).
Comment 3 Mahesh 2015-11-30 05:25:24 UTC
Thanks Nick Burch for the suggestion, I replaced the legacy jars with the latest ones and is working fine with the new one.