Bug 58653 - New JMeter Dashboard/Report with Dynamic Graphs, Tables to help analyzing load test results
Summary: New JMeter Dashboard/Report with Dynamic Graphs, Tables to help analyzing loa...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords: PatchAvailable
: 45589 47302 57516 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-25 17:27 UTC by UbikLoadPack support
Modified: 2016-02-21 22:12 UTC (History)
3 users (show)



Attachments
IP Clearance first try (4.66 KB, application/xml)
2015-11-25 17:45 UTC, Philippe Mouawad
Details
Fix id (4.68 KB, application/xml)
2015-11-25 17:53 UTC, Philippe Mouawad
Details
New version mentioning the partial Sponsorship of developments by Decathlon SA (4.94 KB, text/xml)
2015-11-27 20:13 UTC, Philippe Mouawad
Details
I cannot be the Manager of donation, proposing Milamber :-) (4.94 KB, text/xml)
2015-11-27 20:15 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description UbikLoadPack support 2015-11-25 17:27:08 UTC
UBIK-INGENIERIE/UBIKLOADPACK grants the full rights to Apache to use the code “JMeter Dashboard/Report” donated by initial mail : 
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201510.mbox/%3CCAH9fUpZJPtjfMh60QTKyGHZ8CFuG%3DuGvn9iaE_PhrkhjTb4jkg%40mail.gmail.com%3E


We send today a CCLA with schedule B to mention this donation.

Code currently hosted on :
- https://github.com/ubikloadpack/jmeter 
version 2.14-preview-ubikloadpack-2.0.0 (https://github.com/ubikloadpack/jmeter/tree/2.14-preview-ubikloadpack-2.0.0).

Code has been accepted by Apache JMeter technical vote:
- http://mail-archives.apache.org/mod_mbox/jmeter-dev/201511.mbox/%3C5654EC1E.60102%40apache.org%3E


You can see the output here:

    http://ubikloadpack.com/donations/dashboard/

Version 2.0.0 release has the following features:

    https://github.com/ubikloadpack/jmeter/issues?utf8=%E2%9C%93&q=milestone%3AV2

Remaining enhancements are here, your contributions are welcome:

    https://github.com/ubikloadpack/jmeter/issues?q=is%3Aopen+is%3Aissue+milestone%3AV3

Read user documentation at:

    http://ubikloadpack.com/donations/dashboard/docs/usermanual/generating-dashboard.html

And command line options at:

    http://ubikloadpack.com/donations/dashboard/docs/usermanual/get-started.html#options

If you find any issue (not known) or have an ida of an additional feature feel free to report it at:

- https://github.com/ubikloadpack/jmeter/issues



http://www.ubik-ingenierie.com
@
http://ubikloadpack.com
@ubikloadpack
Comment 1 Philippe Mouawad 2015-11-25 17:45:13 UTC
Created attachment 33296 [details]
IP Clearance first try
Comment 2 Philippe Mouawad 2015-11-25 17:53:33 UTC
Created attachment 33297 [details]
Fix id
Comment 3 Philippe Mouawad 2015-11-27 20:13:19 UTC
Created attachment 33304 [details]
New version mentioning the partial Sponsorship of developments by Decathlon SA
Comment 4 Philippe Mouawad 2015-11-27 20:15:29 UTC
Created attachment 33305 [details]
I cannot be the Manager of donation, proposing Milamber :-)
Comment 5 Milamber 2015-11-28 18:16:11 UTC
Mission accepted! :-)
Comment 7 Milamber 2015-12-06 14:32:12 UTC
The IP Clearance process is finished with success. The integration of JMeter Dashboard/Report code can be done from now into the JMeter source code.

Reference: http://incubator.apache.org/ip-clearance/jmeter-dashboard-report.html (see Related Votes section)
Comment 8 UbikLoadPack support 2015-12-06 14:56:57 UTC
Hello,
Donation being accepted find the PR for most up to date version.

https://github.com/apache/jmeter/pull/41

Donation IP Clearance mentioning V2, we  donate the V3 as part of our CCLA which contains the following fixes and enhancements:
- https://github.com/ubikloadpack/jmeter/issues?utf8=%E2%9C%93&q=+milestone%3AV3+

The V3 is fully sponsored by Ubik-Ingenierie/UbikLoadPack.

UBIK-INGENIERIE/UBIKLOADPACK releases any rights associated to this additional contribution and has of course signed a CCLA.

Regards
Comment 9 Philippe Mouawad 2015-12-06 14:59:09 UTC
Hi,
@Dev Team can I proceed with integration to core ?
Thanks
Comment 10 Philippe Mouawad 2015-12-06 22:42:15 UTC
Hi,
I'll proceed tomorrow with commit of patch
Regards
Comment 11 Philippe Mouawad 2015-12-07 16:58:19 UTC
Author: pmouawad
Date: Mon Dec  7 16:57:16 2015
New Revision: 1718425

URL: http://svn.apache.org/viewvc?rev=1718425&view=rev
Log:
Bug 58653 - New JMeter Dashboard/Report with Dynamic Graphs, Tables to help analyzing load test results
Bugzilla Id: 58653
Comment 12 Philippe Mouawad 2015-12-27 20:45:14 UTC
*** Bug 57516 has been marked as a duplicate of this bug. ***
Comment 13 Philippe Mouawad 2015-12-29 22:31:12 UTC
*** Bug 47302 has been marked as a duplicate of this bug. ***
Comment 14 Sebb 2016-01-10 13:30:14 UTC
URL: http://svn.apache.org/viewvc?rev=1723919&view=rev
Log:
Tab police
Bugzilla Id: 58653

Modified:
    jmeter/trunk/xdocs/usermanual/generating-dashboard.xml

URL: http://svn.apache.org/viewvc?rev=1723918&view=rev
Log:
Unnecessary line wrap
Bugzilla Id: 58653

Modified:
    jmeter/trunk/xdocs/usermanual/generating-dashboard.xml

URL: http://svn.apache.org/viewvc?rev=1723917&view=rev
Log:
Fix error message
(invalid file suggests the file exists but cannot be parsed)
Bugzilla Id: 58653

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/report/dashboard/ReportGenerator.java


URL: http://svn.apache.org/viewvc?rev=1723916&view=rev
Log:
Fix up:
- missing test file name (-t JMX file)
- duplicate anchor
- unnecessary line wrap

Bugzilla Id: 58653

Modified:
    jmeter/trunk/xdocs/usermanual/generating-dashboard.xml
Comment 15 Philippe Mouawad 2016-02-21 22:12:33 UTC
*** Bug 45589 has been marked as a duplicate of this bug. ***