Bug 58707 - Undo/Redo function causes freeze and high memory usage when searching a large .jmx file
Summary: Undo/Redo function causes freeze and high memory usage when searching a large...
Status: RESOLVED DUPLICATE of bug 57043
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-09 11:50 UTC by MarcoP
Modified: 2015-12-09 20:44 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MarcoP 2015-12-09 11:50:52 UTC
To reproduce:

1)Enable the undo.history.size property. It was initially set at 25 but even 5 was causing an issue

2)Open a relatively large JMX script (just opening the script is already slower when undo is active)

3)Carry out a search. If the script is large enough JMeter will consume all memory made available to it while trying to carry out the search and will freeze.

Turning off the undo.history.size property and repeating the above steps after restarting JMeter shows much improved performance and does not freeze the application.
Comment 1 benoit.wiart 2015-12-09 18:03:38 UTC
Could you provide the jmx script ?
Comment 2 Philippe Mouawad 2015-12-09 20:44:00 UTC
Hi,
This is a known issue of Undo/Redo feature, this is why the feature is disabled by default.

Closing as duplicate.

*** This bug has been marked as a duplicate of bug 57043 ***