Bug 58756 - CookieManager : Cookie Policy select box content must depend on Cookie implementation
Summary: CookieManager : Cookie Policy select box content must depend on Cookie implem...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.13
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on: 59069 59071
Blocks:
  Show dependency tree
 
Reported: 2015-12-20 16:07 UTC by Philippe Mouawad
Modified: 2016-02-27 12:53 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2015-12-20 16:07:30 UTC
Make select box content depend on Cookie implementation.
Comment 1 Philippe Mouawad 2015-12-20 16:10:08 UTC
Author: pmouawad
Date: Sun Dec 20 16:09:49 2015
New Revision: 1721041

URL: http://svn.apache.org/viewvc?rev=1721041&view=rev
Log:
Bug 58756 - CookieManager : Cookie Policy select box content must depend on Cookie implementation
Bugzilla Id: 58756

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/HC3CookieHandler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/HC4CookieHandler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/gui/CookiePanel.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2016-02-25 22:07:06 UTC
After fix to Bug 58756, default was used as the default policy.

But this is wrong as:
- HttpHC3Impl used "compabitility" as default
- HttpHC4Impl should use "standard" as default  (This explains the reported
issue by Maxime Chassagneux on Mailing list related to dates parsing)

The issue is that when reading a 2.13 saved JMX from a 3.0, as default have
changed, the default values are not in JMX file so we end up initializing
different values.
Comment 3 Philippe Mouawad 2016-02-25 22:07:56 UTC
*** Bug 59071 has been marked as a duplicate of this bug. ***
Comment 4 Philippe Mouawad 2016-02-25 22:15:59 UTC
Author: pmouawad
Date: Thu Feb 25 22:10:00 2016
New Revision: 1732387

URL: http://svn.apache.org/viewvc?rev=1732387&view=rev
Log:
Bug 58756 - CookieManager : Cookie Policy select box content must depend on Cookie implementation

After fix to Bug 58756, default was used as the default policy.

But this is wrong as:
- HttpHC3Impl used "compabitility" as default
- HttpHC4Impl should use "standard" as default  (This explains the reported
issue by Maxime Chassagneux on Mailing list related to dates parsing)
Bugzilla Id: 58756

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/CookieHandler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/CookieManager.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/HC3CookieHandler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/HC4CookieHandler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/gui/CookiePanel.java
Comment 5 Philippe Mouawad 2016-02-27 12:17:11 UTC
Author: sebb
Date: Sat Feb 27 01:39:02 2016
New Revision: 1732593

URL: http://svn.apache.org/viewvc?rev=1732593&view=rev
Log:
Change default to HC4/standard
Bugzilla Id: 58756

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/HC4CookieHandler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/gui/CookiePanel.java

Author: sebb
Date: Sat Feb 27 02:12:02 2016
New Revision: 1732595

URL: http://svn.apache.org/viewvc?rev=1732595&view=rev
Log:
Fix bug whereby policy was sometimes reset when navigating between HC3 and HC4 Cookie Configs
Bugzilla Id: 58756

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/gui/CookiePanel.java
Comment 6 Philippe Mouawad 2016-02-27 12:53:49 UTC
Author: pmouawad
Date: Sat Feb 27 12:53:18 2016
New Revision: 1732634

URL: http://svn.apache.org/viewvc?rev=1732634&view=rev
Log:
Bug 58756 - CookieManager : Cookie Policy select box content must depend on Cookie implementation
A) Fix bug introduced by commit r1732632:
1/ Save with 2.13 a Plan containing CookieManager that uses defaults
2/ Open it with trunk
3/ It is ok
4/ Close it
5/ Add a new CookieManager => KO the policy is default instead of standard


B) Also made constants explicit and removed dependency on deprecated class.

C) Forced the save of policy and implementation even if there values are set at defaults to avoid this headache again


Bugzilla Id: 58756

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/CookieManager.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/gui/CookiePanel.java