Bug 58814 - JVM don't recognize option MaxLiveObjectEvacuationRatio
Summary: JVM don't recognize option MaxLiveObjectEvacuationRatio
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.0.1
Hardware: PC Linux
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-07 00:26 UTC by kapsh
Modified: 2016-01-07 23:45 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kapsh 2016-01-07 00:26:49 UTC
Oracle hotspot vm ver 1.8.0_66 raises an error when I am trying launch jmeter:

Unrecognized VM option 'MaxLiveObjectEvacuationRatio=20'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

So I can't run gui until I commented out this option in startup script or used IcedTea which just shows a warning: 
OpenJDK 64-Bit Server VM warning: ignoring option MaxLiveObjectEvacuationRatio=20; support was removed in 6.0_24

Problem on my system was in file /opt/jmeter/bin/jmeter on line: 
EVACUATION="-XX:MaxLiveObjectEvacuationRatio=20"
Comment 1 Philippe Mouawad 2016-01-07 12:13:05 UTC
Bugzilla is not a support forum.
Besides this question has no relation with JMeter.
Most probably your Java version does not havee these options.
Comment 2 Sebb 2016-01-07 12:58:39 UTC
(In reply to Philippe Mouawad from comment #1)
> Besides this question has no relation with JMeter.

The file in question is part of JMeter.

> Most probably your Java version does not havee these options.

That is true; the problem is that Java 8 fails to start rather than warning that it cannot process the option.

For the command-line:

$ java -XX:MaxLiveObjectEvacuationRatio=20 -version

Java 7 gives:
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxLiveObjectEvacuationRatio=20; support was removed in 6.0_24
java version "1.7.0_79"

Java 8 gives:
Unrecognized VM option 'MaxLiveObjectEvacuationRatio=20'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

I think this is unfortunate behaviour of the JVM (possibly a bug), but since JMeter requires at least Java 7, the option should be removed from any scripts.
Comment 3 Sebb 2016-01-07 13:14:06 UTC
Further investigation shows that the setting was commented out since at least v 2.5.1.

However the option is now completely redundant and should be removed to avoid confusion.

Note: if you really are using version 2.0.1, you really should upgrade as that is ancient.
Comment 4 Sebb 2016-01-07 13:32:02 UTC
URL: http://svn.apache.org/viewvc?rev=1723538&view=rev
Log:
JVM don't recognize option MaxLiveObjectEvacuationRatio; remove from comments
Bugzilla Id: 58814

Modified:
    jmeter/trunk/bin/jmeter
    jmeter/trunk/bin/jmeter.bat
    jmeter/trunk/xdocs/changes.xml
Comment 5 kapsh 2016-01-07 23:45:15 UTC
(In reply to Sebb from comment #3)
> Further investigation shows that the setting was commented out since at
> least v 2.5.1.
> 
> However the option is now completely redundant and should be removed to
> avoid confusion.
> 
> Note: if you really are using version 2.0.1, you really should upgrade as
> that is ancient.

Okay, thanks. It seems like my distro has not newer version yet so I was misleaded.