Bug 58841 - BackendListener : Allow samplersList to be a regex
Summary: BackendListener : Allow samplersList to be a regex
Status: RESOLVED DUPLICATE of bug 59099
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-12 13:56 UTC by mchassagneux
Modified: 2016-03-03 20:28 UTC (History)
1 user (show)



Attachments
Add avg metric and regex for samplersList. (7.81 KB, patch)
2016-01-12 13:56 UTC, mchassagneux
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mchassagneux 2016-01-12 13:56:56 UTC
Created attachment 33427 [details]
Add avg metric and regex for samplersList.

Hi, 

I use the backendlistner to send metric on InfluxDB. So far, I didn't understand how i could find the average response time from current metric. Only min max, but no way to calculate average. 

So, I made this patch to send new metric to influxdb. 

I've made also a modification, to change the behaviour of the samplersList. I think it's better and more power to use a regex to select which sampler you want.
Comment 1 Philippe Mouawad 2016-01-16 09:09:46 UTC
Hello,
Thanks for contribution.
Avg metric has no real value in Load Testing so I don't think it should be added.
Regarding the switch to regexp, it seems a good idea but introduces a backward incompatibility.

What do other team members think ?
Regards
Philippe
Comment 2 mchassagneux 2016-01-16 10:31:06 UTC
I'm working on a PTO team (Permit To Operate) and made dozen of test by week. All projects need to known the average response time of each transaction.
I use influxdb / grafana for create report, and I really need to know the average response time of each transaction...
Comment 3 Philippe Mouawad 2016-01-16 13:06:16 UTC
Why don't you use percentiles ?:
https://blog.optimizely.com/2013/12/11/why-cdn-balancing/
Comment 4 mchassagneux 2016-01-18 10:12:51 UTC
I also use percentiles, but all the datas feedback system we use (like introscope etc..) only use avg metric. So in term of comparaison between acceptance environnement and production I only use avg metric. 

Furthermore, in term of communication report, for most of users, the avg metric is more significant than percentile.
Comment 5 Philippe Mouawad 2016-02-08 12:06:01 UTC
Hello,
Avg is a misleading and meaningless metric so I am not keen on having it by default.

If team agrees, a possible option would be to enable it by an additional property. 
Can you open discussion on dev mailing list, and if ok for others and if you provide a patch for this , we could integrated it.

Regards
Philippe
Comment 6 Antonio Gomes Rodrigues 2016-02-18 12:49:59 UTC
Hi,

I think to have the possibility to use a list or regexp to select which sampler we want to have in InfluxDB is very great

Antonio
Comment 7 Philippe Mouawad 2016-02-27 09:25:37 UTC
Renaming issue to only keep the possibility to use a Regex instead of a list
Comment 8 Philippe Mouawad 2016-03-03 20:28:37 UTC

*** This bug has been marked as a duplicate of bug 59099 ***