Bug 58996 - Change in API from 3.11 to 3.13 (setFillForegroundColor +setFillPattern)
Summary: Change in API from 3.11 to 3.13 (setFillForegroundColor +setFillPattern)
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.13-FINAL
Hardware: All Linux
: P2 minor (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on: 56295
Blocks:
  Show dependency tree
 
Reported: 2016-02-11 15:06 UTC by Bengt Söderberg
Modified: 2016-02-12 09:46 UTC (History)
0 users



Attachments
Testcase (13.15 KB, application/zip)
2016-02-11 15:06 UTC, Bengt Söderberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bengt Söderberg 2016-02-11 15:06:45 UTC
Created attachment 33547 [details]
Testcase

While updating poi from 3.11 to 3.13 some of our tests failed, we're working around it for now but just thought I'd report it in as a bug as it's a change in the API that might be unintended. Attaching necessary code to reproduce problem, works in 3.11 but fails in 3.13
Comment 1 Dominik Stadler 2016-02-12 08:12:14 UTC
Changes in r1666736 bug 56295 seem related here.
Comment 2 Dominik Stadler 2016-02-12 09:46:08 UTC
Should be fixed in time for 3.14 via r1729964, changelog via r1729966