Bug 59005 - HTTP Request sampler method "SEARCH" is missing for Webdav
Summary: HTTP Request sampler method "SEARCH" is missing for Webdav
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.13
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 57107 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-15 05:39 UTC by Abhay Dubey
Modified: 2016-02-27 09:38 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Abhay Dubey 2016-02-15 05:39:11 UTC
HTTP Request sampler method "SEARCH" is missing for Webdav
Comment 1 Felix Schumacher 2016-02-15 20:09:12 UTC
Date: Mon Feb 15 20:08:25 2016
New Revision: 1730604

URL: http://svn.apache.org/viewvc?rev=1730604&view=rev
Log:
HTTP Sampler : Added WebDAV verb (SEARCH).

Bugzilla Id: 59005

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSamplerBase.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/HTTPConstantsInterface.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 2 Abhay Dubey 2016-02-16 06:28:05 UTC
Unable to use SEARCH method, getting:
java.lang.IllegalArgumentException: Unexpected method: 'SEARCH'
	at org.apache.jmeter.protocol.http.sampler.HTTPHC4Impl.sample(HTTPHC4Impl.java:312)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerProxy.sample(HTTPSamplerProxy.java:74)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1145)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1134)
	at org.apache.jmeter.threads.JMeterThread.executeSamplePackage(JMeterThread.java:446)
	at org.apache.jmeter.threads.JMeterThread.processSampler(JMeterThread.java:391)
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:240)
	at java.lang.Thread.run(Unknown Source)

I think below mentioned files need to be modified:

    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HttpWebdav.java   (with props)

    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSampleResult.java

Reference Bug ID: Bug 57107
Comment 3 Felix Schumacher 2016-02-16 17:41:25 UTC
Date: Tue Feb 16 17:36:36 2016
New Revision: 1730724

URL: http://svn.apache.org/viewvc?rev=1730724&view=rev
Log:
Followup to r1730604

HTTP Sampler : Added WebDAV verb (SEARCH). Add missing changes to HttpWebDav.

Bugzilla Id: 59005


Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HttpWebdav.java
Comment 4 Philippe Mouawad 2016-02-27 09:38:33 UTC
*** Bug 57107 has been marked as a duplicate of this bug. ***