Bug 59020 - Performance : Avoid useless SSL Context initialization when HTTPClient4 is used
Summary: Performance : Avoid useless SSL Context initialization when HTTPClient4 is used
Status: RESOLVED DUPLICATE of bug 58099
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.13
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-17 18:43 UTC by Philippe Mouawad
Modified: 2016-02-17 18:46 UTC (History)
1 user (show)



Attachments
Patch fixing this issue (9.25 KB, patch)
2016-02-17 18:44 UTC, Philippe Mouawad
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-02-17 18:43:05 UTC
as per this discussion:
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201405.mbox/%3CCAH9fUpYOgA_TatgwF8K2EmzwcL0DSSkUiR0GZ9vVQVEJL9oN5A%40mail.gmail.com%3E


SSL eager initialization is a performance issue (that is nearly a blocker for embedded resources download and particularly Bug 52073).
Comment 1 Philippe Mouawad 2016-02-17 18:44:51 UTC
Created attachment 33566 [details]
Patch fixing this issue
Comment 2 Philippe Mouawad 2016-02-17 18:46:02 UTC

*** This bug has been marked as a duplicate of bug 58099 ***