Bug 59050 - Unable to create SXSSF work book in unix environment with JBOSS dev studio 4.0
Summary: Unable to create SXSSF work book in unix environment with JBOSS dev studio 4.0
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: SXSSF (show other bugs)
Version: 3.13-FINAL
Hardware: Other All
: P2 blocker (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-23 07:05 UTC by Ratna
Modified: 2016-04-05 12:11 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ratna 2016-02-23 07:05:44 UTC
Hi Team,

We are trying to upgrade apache poi version from 3.8 beta to 3.13.
While we deployed the code in JBOSS server,
it is blocking for us.we are not getting any exception eventhough we tried to catch the same in catch block.DOnt know what is the error also.
we upgraded all poi jars to 3.13.
after the below code,its doing nothing.

Workbook workbook=new SXSSFWorkbook(new XSSFWorkbook (fileInputStream));

where as in our local win7,jboss 4 it is working fine.
it is not working unix jboss server.

Kindly please help on this and let me know,any information needed.
Comment 1 Nick Burch 2016-02-23 12:13:59 UTC
You could try with Apache POI 3.14 beta 1, or even a recent nightly build, in case it's something fixed recently.

Otherwise, since creating workbooks works just fine for everyone else on every other environment, it sounds like a JBOSS bug and something you'd need to take up with their support.
Comment 2 Dominik Stadler 2016-02-23 13:25:10 UTC
Hm, do you have at least a stacktrace dump of the java process when it blocks? Otherwise there is just not enough information to state anything here...
Comment 3 Dominik Stadler 2016-02-27 08:44:14 UTC
I don't see how this can possibly be caused by POI. So unless we get some more information here I don't think there is anything that we can do, thus resolving this for now, please reopen with more information if you think POI is actually related here.
Comment 4 Ratna 2016-03-03 11:49:55 UTC
Hello Team,
Iam reopening this ticket,as i have following summary on the same.
We removed Java-stax-api.jar and is now working for english template.
But while we are trying to write data in French Template,we are getting the following exception.Kindly please help.

[‎03-‎03-‎2016 17:15] Lal, Divya: 
Attempting to write a row[1] in the range [0,1] that is already written to disk.
The 7 elements of the stack trace:
	org.apache.poi.xssf.streaming.SXSSFSheet.createRow(SXSSFSheet.java:120)
	org.apache.poi.xssf.streaming.SXSSFSheet.createRow(SXSSFSheet.java:54)
	rntbci.isdc.sfe.alert.export.batch.AlertExportBatchProcess.writeGenSheetData(AlertExportBatchProcess.java:1685)
Comment 5 Ratna 2016-03-04 06:22:30 UTC
Hi all,
here are some more details regarding the ticket.

1.in the ENglish template,if we changed to french header,its working fine.
2.In the english template,if we copy all the french sheets,its not working.

Also the same french template is working in web environment,but backend (Batch)  is not working.

Thanks
Ratna
Comment 6 Dominik Stadler 2016-03-13 21:11:10 UTC
Can you share the files and some standalone code (preferrably as unit-test) that reproduces the problem? Otherwise it's very hard to reproduce
Comment 7 Dominik Stadler 2016-04-05 12:11:09 UTC
Please reopen this bug when you can attach sample documents here, otherwise there is not much we can do...