Bug 59076 - Test should fail if a module controller cannot find its replacement subtree
Summary: Test should fail if a module controller cannot find its replacement subtree
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: Other AIX
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks: 59169
  Show dependency tree
 
Reported: 2016-02-26 16:45 UTC by benoit.wiart
Modified: 2016-03-12 14:44 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description benoit.wiart 2016-02-26 16:45:00 UTC
The user is afraid of using this controller and fear is the path to the dark side…  fear leads to anger… anger leads to hate… hate leads to suffering.
Comment 1 Sebb 2016-02-27 00:53:41 UTC
This is not a valid bug report.

Please provide factual statements only.
Comment 2 Philippe Mouawad 2016-02-29 08:45:29 UTC
This bug is very clear and I have faced it many times without being able to find the exact reproduction scenario although most probably the cause is that there is no unique id for each test element.


What happens is that sometimes you open your Test plan and I don't know for which reason, Module Controllers have lost the references to the target controller. 

So ideally we should fix the issue and at least inform user of the problem by failing.
Comment 3 benoit.wiart 2016-02-29 09:54:48 UTC
We have a root pb -> the module controller is sometime loosing its target replacement tree.
I don't think there is a bug for this.

I've opened Bug 58675 and this one are to make sure the user will not miss this pb.
It should not be possible to execute the test if one of the module controller has a missing replacement tree.

@sebb This bug is perfectly valid.
Comment 4 Sebb 2016-02-29 11:27:14 UTC
(In reply to benoit.wiart from comment #3)
> @sebb This bug is perfectly valid.

I did not say the bug wasn't valid.

The Description does not describe the problem; as such it is an invalid report.
Comment 5 benoit.wiart 2016-02-29 15:52:05 UTC
(In reply to Sebb from comment #4)
> (In reply to benoit.wiart from comment #3)
> > @sebb This bug is perfectly valid.
> 
> I did not say the bug wasn't valid.
> 
> The Description does not describe the problem; as such it is an invalid
> report.

Needinfo is usually used for this :-(
Closing it was rude.
Comment 6 benoit.wiart 2016-03-01 14:47:48 UTC
the test <jmeter>/bin/testfiles/Bug47165.jmx is a good test case.
When I open it in jmeter 2.13, the module controllers are 'corrupted'
Comment 7 Philippe Mouawad 2016-03-11 20:38:35 UTC
I think one of scenario for the loss of referenced Controller is due to the renaming of Test Plan.
Comment 8 Philippe Mouawad 2016-03-11 20:43:25 UTC
(In reply to Philippe Mouawad from comment #7)
> I think one of scenario for the loss of referenced Controller is due to the
> renaming of Test Plan.

Renaming of any Test Element referenced by the ModuleController.node_path.
Comment 9 Philippe Mouawad 2016-03-11 21:16:25 UTC
Author: pmouawad
Date: Fri Mar 11 21:11:18 2016
New Revision: 1734632

URL: http://svn.apache.org/viewvc?rev=1734632&view=rev
Log:
Bug 59076 - Test should fail if a module controller cannot find its replacement subtree
Bugzilla Id: 59076

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/control/ModuleController.java
    jmeter/trunk/xdocs/changes.xml
Comment 10 Philippe Mouawad 2016-03-12 14:44:57 UTC
Author: pmouawad
Date: Sat Mar 12 14:44:03 2016
New Revision: 1734711

URL: http://svn.apache.org/viewvc?rev=1734711&view=rev
Log:
Bug 59076 - Test should fail if a module controller cannot find its replacement subtree
Take into account sebb note
Bugzilla Id: 59076

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/control/ModuleController.java