Bug 59112 - mod_fcgid breaks apachectl graceful
Summary: mod_fcgid breaks apachectl graceful
Status: RESOLVED DUPLICATE of bug 48769
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_fcgid (show other bugs)
Version: 2.4.18
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-04 02:19 UTC by apache-bugs.a2
Modified: 2016-03-04 21:10 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description apache-bugs.a2 2016-03-04 02:19:03 UTC
mod_fcgid 2.3.6,2.3.7, 2.3.9 and probably all ealier breaks apachectl graceful (even apache requests that do not use fcgid)
mod_fcgid + suexec: default settings, adaptive spawn with socket communication
os: linux

How to recreate:
run in browser http://localhost/a.php and http://localhost/b.php at the same time 
a.php and b.php has content:
<?
sleep(99999);

problem will not occur if only one script is running at the same time.
You can also at the same time initate download from for example http://localhost/my.file.bz2

initiate apachectl gracefull

either all 3 requests will be terminated (and download broken) or 2 of them (and 1 will continue). All 3 should continue.
If only 1 request is running then there is no problem.

Did anyone actualy tested apachectl graceful when there is more that 1 fcgid process/hander running?
Comment 1 apache-bugs.a2 2016-03-04 21:10:21 UTC

*** This bug has been marked as a duplicate of bug 48769 ***