Bug 59559 - Rule M2.4 exception : this error should NEVER happen!
Summary: Rule M2.4 exception : this error should NEVER happen!
Status: RESOLVED DUPLICATE of bug 60102
Alias: None
Product: POI
Classification: Unclassified
Component: SXSSF (show other bugs)
Version: 3.13-FINAL
Hardware: Macintosh All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 60180 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-17 05:48 UTC by Kabel
Modified: 2016-09-27 15:57 UTC (History)
1 user (show)



Attachments
Use SXSSF to manipulate a template excel file. (5.46 KB, text/plain)
2016-05-17 05:48 UTC, Kabel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kabel 2016-05-17 05:48:32 UTC
Created attachment 33844 [details]
Use SXSSF to manipulate a template excel file.
Comment 1 Dominik Stadler 2016-05-17 08:46:21 UTC
Please provide a more self-sufficient piece of code as this one depends on many things that are only available to you. Otherwise nobody will be able to reproduce your problem and look for a possible cause or fix.
Comment 2 Dominik Stadler 2016-07-26 20:35:57 UTC
Setting this one to resolved until we get some more information that allows others to reproduce the problem.
Comment 3 Javen O'Neal 2016-09-17 18:28:52 UTC
> OPCPackage pkg = OPCPackage.open(new File(ctxPath));
> XSSFWorkbook wb_template = new XSSFWorkbook(pkg);
> pkg.close();
> SXSSFWorkbook workbook = new SXSSFWorkbook(wb_template, CACHE_SIZE);

You are probably getting the error here where you are to created a workbook from a closed resource. You must keep the source workbook and the source OPCPackage open until after the SXXSFWorkbook has been opened.
Comment 4 Javen O'Neal 2016-09-27 15:51:22 UTC
*** Bug 60180 has been marked as a duplicate of this bug. ***
Comment 5 Javen O'Neal 2016-09-27 15:57:43 UTC

*** This bug has been marked as a duplicate of bug 60102 ***