Bug 59625 - Localisation (Internationalisation in other languages) when applied in charts corrupt the MS Word file.
Summary: Localisation (Internationalisation in other languages) when applied in charts...
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XWPF (show other bugs)
Version: 3.14-FINAL
Hardware: PC All
: P2 critical (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-24 12:44 UTC by Chenna Kesavarao
Modified: 2018-10-03 08:28 UTC (History)
1 user (show)



Attachments
shows correct localisation in excel, while same corrupts the file in MS Word (19.49 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-05-24 12:44 UTC, Chenna Kesavarao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chenna Kesavarao 2016-05-24 12:44:45 UTC
Created attachment 33872 [details]
shows correct localisation in excel, while same corrupts the file in MS Word

Localisation when applied in charts in MS word corrupts the file. WHile the same things works properly with ppt and excel.

Also Hindi Localisation in MS Word is giving Boxes.
Comment 1 Mark Murphy 2016-07-08 11:48:05 UTC
Please attach the Word document as well. There are differences between how Word and Excel use the chart part. Particularly in how the chart data is referenced.
Look at the Open Office XML 1st edition Part 1: Fundamentals, December 2006 p. 125 lines 8-17.

I can't tell what the issue is without the word document. I suspect that you are generating much of the XML yourself using the CT classes since the Word API (and charts) is incomplete.
Comment 2 Alain Fagot Bearez 2018-10-03 08:28:24 UTC
With recent code changes, BarChartExample creates a bar chart using diverse scripts that can be opened as well in MS Word as in LibreOffice.

I used the data from https://www.ethnologue.com/statistics/size for number of countries and speakers, as well as https://www.omniglot.com/language/names.htm for the name of the languages in the proper language.

resolved by r1842687