Bug 59652 - FormulaParseException from whitespace
Summary: FormulaParseException from whitespace
Status: RESOLVED DUPLICATE of bug 58648
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.14-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on: 58648
Blocks:
  Show dependency tree
 
Reported: 2016-06-01 18:25 UTC by scott.paffrath
Modified: 2016-08-13 20:43 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description scott.paffrath 2016-06-01 18:25:18 UTC
Both HSSF and XSSF throw this exception now when there is whitespace between elements and closing parenthesis. I jumped from 3.12 to 3.14 so not sure if this was in 3.13 or not.

    public static void main(String[] args)
    {
        XSSFWorkbook wb = new XSSFWorkbook();
        XSSFSheet sheet = wb.createSheet();
        Row row = sheet.createRow(0);

        Cell cell = row.createCell(0);
        cell.setCellFormula("(4 + 2)"); // This works

        cell = row.createCell(1);
        cell.setCellFormula("( 4 + 2)"); // This works

        cell = row.createCell(2);
        cell.setCellFormula("(4 + 2 )"); // FormulaParseException
    }
Comment 1 Dominik Stadler 2016-06-01 19:24:48 UTC
Sounds like a duplicate of 58648, can you try with a nightly build from https://builds.apache.org/view/POI/job/POI/lastSuccessfulBuild/artifact/build/dist/ to verify that your cases were also fixed by these changes.
Comment 2 scott.paffrath 2016-06-01 21:31:32 UTC
It is a duplicate and the nightly build fixes it. Thank you.
Comment 3 Dominik Stadler 2016-08-13 20:43:25 UTC
Fixed by the fix for bug 58648.

*** This bug has been marked as a duplicate of bug 58648 ***