Bug 59891 - Manager deployment selection munges WAR file name
Summary: Manager deployment selection munges WAR file name
Status: RESOLVED DUPLICATE of bug 59115
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Manager (show other bugs)
Version: 8.5.4
Hardware: PC All
: P2 normal (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-21 18:53 UTC by s05marti
Modified: 2016-07-21 19:54 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description s05marti 2016-07-21 18:53:54 UTC
I downloaded Tomcat 8.5.4 from the Apache Tomcat webite as a zip file for Windows 64 bit. I configured the tomcat-users.xml file  to allow access to the manager. Tomcat starts up and I can get to the manager page. I selected a WAR file to deploy. The full path to the WAR file displays with backslashes in the path, as is typical of a Windows installation. I click on "Deploy". 

Tomcat strips out the backslashes and tries to load the WAR file with no directory separators in the path. In the applications list it displays this munged name as if it were the application. It fails to load the WAR file because it can not find the file. Tomcat 6 and 7 do not have this problem. I have not tried this on a Unix system.
Note that I can manually copy the WAR file to the webapps directory and then it will auto-deploy correctly. The problem is that the manager module munges the WAR file path and thus fails to find the file.
Comment 1 Mark Thomas 2016-07-21 19:54:58 UTC
The root cause of this behaviour is the non-specifciation compliance of IE. See the duplicate for details. You should raise a bug with Microsoft.

*** This bug has been marked as a duplicate of bug 59115 ***