Bug 59954 - Web Report/Dashboard : Add average metric
Summary: Web Report/Dashboard : Add average metric
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 59971 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-06 13:45 UTC by Philippe Mouawad
Modified: 2016-08-11 08:46 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-08-06 13:45:53 UTC
Related to Bug 59953.
Since 3.0 was released we have been asked many times to add this avg
metric:
- http://stackoverflow.com/questions/38315631/is-jmeter-3-0-report-generator-dashboard-missing-average-in-the-statistics-tab
- http://stackoverflow.com/questions/38404652/how-do-i-get-the-average-response-time-in-jmeter-3-0-dashboard

I was also requested many times during my load testing work to provide this
metric.
So although it is not as meaningful as percentiles (which should be used) I
suggest we add it as it is also provided by Summary report.
Comment 1 Philippe Mouawad 2016-08-06 14:01:34 UTC
Author: pmouawad
Date: Sat Aug  6 14:00:37 2016
New Revision: 1755399

URL: http://svn.apache.org/viewvc?rev=1755399&view=rev
Log:
Bug 59954 - Web Report/Dashboard : Add average metric
Bugzilla Id: 59954

Modified:
    jmeter/trunk/bin/report-template/content/js/dashboard.js.fmkr
    jmeter/trunk/src/core/org/apache/jmeter/report/processor/StatisticsSummaryConsumer.java
    jmeter/trunk/src/core/org/apache/jmeter/report/processor/StatisticsSummaryData.java
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/xdocs/changes.xml
Comment 2 UbikLoadPack support 2016-08-11 08:46:18 UTC
*** Bug 59971 has been marked as a duplicate of this bug. ***