Bug 59964 - JSR223 Test Element : Cache compiled script if available is not correctly reset
Summary: JSR223 Test Element : Cache compiled script if available is not correctly reset
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 60269 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-10 13:02 UTC by UbikLoadPack support
Modified: 2016-10-18 18:36 UTC (History)
2 users (show)



Attachments
Patch fixing the issue (1.15 KB, patch)
2016-08-11 18:35 UTC, UbikLoadPack support
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description UbikLoadPack support 2016-08-10 13:02:14 UTC
You have at least 2 JSR223 Elements in your plan.
Do the following:
- Check the checkbox in first one
- Check the checkbox in first one
- Uncheck it in the second one
- Go to first one
- Go back to second one, it is checked again => KO


Note issue also occurs in following scenario:
- New Test Plan
- Add JSR223 PostProcessor, check checkbox
- Add a second one, checkbox is already checked => KO
Comment 1 UbikLoadPack support 2016-08-11 18:35:42 UTC
Created attachment 34137 [details]
Patch fixing the issue
Comment 2 Philippe Mouawad 2016-08-11 18:56:59 UTC
Date: Thu Aug 11 18:56:09 2016
New Revision: 1756029

URL: http://svn.apache.org/viewvc?rev=1756029&view=rev
Log:
Bug 59964 - JSR223 Test Element : Cache compiled script if available is not correctly reset
Contributed by Ubik Load Pack
Bugzilla Id: 59964

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/util/ScriptingBeanInfoSupport.java
    jmeter/trunk/xdocs/changes.xml
Comment 3 Philippe Mouawad 2016-10-18 18:36:52 UTC
*** Bug 60269 has been marked as a duplicate of this bug. ***