Bug 60049 - When using Timers with high delays or Constant Throughput Timer with low throughput, Scheduler may take a lot of time to exit, same for Shutdown test
Summary: When using Timers with high delays or Constant Throughput Timer with low thro...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-26 19:31 UTC by Philippe Mouawad
Modified: 2016-10-24 19:30 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-08-26 19:31:08 UTC
When using Constant Throughput Timer (CTP° + Scheduler with a duration of script, if expected Target Throughput is very low, CTP will compute a big delay that can go above the end of test.

The only option to stop test in this case is to call stop, shutdown will face the same issue as timer is not interrupted.


Issue exists since the origin.
Comment 1 Philippe Mouawad 2016-08-28 21:10:44 UTC
Author: pmouawad
Date: Sun Aug 28 21:10:13 2016
New Revision: 1758151

URL: http://svn.apache.org/viewvc?rev=1758151&view=rev
Log:
Bug 60049 - When using Timers with high delays or Constant Throughput Timer with low throughput, Scheduler may take a lot of time to exit, same for Shutdown test
Bugzilla Id: 60049

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/threads/JMeterThread.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2016-08-30 09:28:07 UTC
Date: Tue Aug 30 09:26:05 2016
New Revision: 1758348

URL: http://svn.apache.org/viewvc?rev=1758348&view=rev
Log:
Bug 60049 - When using Timers with high delays or Constant Throughput Timer with low throughput, Scheduler may take a lot of time to exit, same for Shutdown test
Comment code
Bugzilla Id: 60049

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/threads/JMeterThread.java
Comment 3 Gian Franco Zabarino 2016-10-24 19:27:53 UTC
Hi people. I'm new to the project, actually got here because of some behavior I'm getting when executing tests.

I'm testing with a fixed duration and I'm getting a 10x increase of hits/sec in the last 10 secs or so of the test. I'm using some timers to delay the execution of samplers for about 10 seconds, and seeing JMeter's code it makes sense what's happening. However, shouldn't the expected behavior to not sample samplers that would be executed after the load test's end time? Correct me if I'm wrong but what this does is to execute all of those tests (that would be executed at the test's end time) in the millisecond when the thread group would end. I'm getting the because after the delay there's the sampling code.
Comment 4 Gian Franco Zabarino 2016-10-24 19:30:07 UTC
* I'm getting (as in, understand) this because after the delay there's the sampling code.

(In reply to Gian Franco Zabarino from comment #3)
> Hi people. I'm new to the project, actually got here because of some
> behavior I'm getting when executing tests.
> 
> I'm testing with a fixed duration and I'm getting a 10x increase of hits/sec
> in the last 10 secs or so of the test. I'm using some timers to delay the
> execution of samplers for about 10 seconds, and seeing JMeter's code it
> makes sense what's happening. However, shouldn't the expected behavior to
> not sample samplers that would be executed after the load test's end time?
> Correct me if I'm wrong but what this does is to execute all of those tests
> (that would be executed at the test's end time) in the millisecond when the
> thread group would end. I'm getting the because after the delay there's the
> sampling code.