Bug 60111 - Compilation error of httpd 2.4.23 with openssl 1.1.0
Summary: Compilation error of httpd 2.4.23 with openssl 1.1.0
Status: RESOLVED DUPLICATE of bug 60061
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: All (show other bugs)
Version: 2.4.23
Hardware: PC Linux
: P2 blocker (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-10 13:18 UTC by bhamichi
Modified: 2016-09-10 13:20 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bhamichi 2016-09-10 13:18:33 UTC
Hi,

I was getting a blocking issue when I try to compile httpd-2.4.23 with openssl-1.1.0 (working under CentOS7).

Could you please help. 

Thanks in advance

Best Regards,



 
Configure command: OK

[root@localhost httpd-2.4.23]# ./configure --prefix=/usr/local/apache/$ASIP_HTTPD --enable-ssl -enable-mods-shared=ssl --with-apr=/usr/local/apr/$ASIP_APR --with-apr-util=/usr/local/apr-util/$ASIP_APR_UTIL --with-ssl=/usr/local/openssl/$ASIP_OPENSSL

MAKE command: NOK

Following reported issues:


          ############# START LOG ################

...
...
...

ssl_engine_init.c: In function 'make_dh_params':
ssl_engine_init.c:61:7: error: dereferencing pointer to incomplete type
     dh->p = prime(NULL);
       ^
ssl_engine_init.c:62:18: error: dereferencing pointer to incomplete type
     BN_dec2bn(&dh->g, gen);
                  ^
ssl_engine_init.c:63:12: error: dereferencing pointer to incomplete type
     if (!dh->p || !dh->g) {
            ^
ssl_engine_init.c:63:22: error: dereferencing pointer to incomplete type
     if (!dh->p || !dh->g) {
                      ^
ssl_engine_init.c: In function 'ssl_init_ctx_protocol':
ssl_engine_init.c:519:13: warning: 'TLSv1_client_method' is deprecated (declared at /usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:1598) [-Wdeprecated-declarations]
             TLSv1_client_method() : /* proxy */
             ^
ssl_engine_init.c:520:13: warning: 'TLSv1_server_method' is deprecated (declared at /usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:1597) [-Wdeprecated-declarations]
             TLSv1_server_method();  /* server */
             ^
ssl_engine_init.c:525:13: warning: 'TLSv1_1_client_method' is deprecated (declared at /usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:1604) [-Wdeprecated-declarations]
             TLSv1_1_client_method() : /* proxy */
             ^
ssl_engine_init.c:526:13: warning: 'TLSv1_1_server_method' is deprecated (declared at /usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:1603) [-Wdeprecated-declarations]
             TLSv1_1_server_method();  /* server */
             ^
ssl_engine_init.c:530:13: warning: 'TLSv1_2_client_method' is deprecated (declared at /usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:1610) [-Wdeprecated-declarations]
             TLSv1_2_client_method() : /* proxy */
             ^
ssl_engine_init.c:531:13: warning: 'TLSv1_2_server_method' is deprecated (declared at /usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:1609) [-Wdeprecated-declarations]
             TLSv1_2_server_method();  /* server */
             ^
ssl_engine_init.c: In function 'ssl_init_ctx_session_cache':
ssl_engine_init.c:641:9: warning: passing argument 2 of 'SSL_CTX_sess_set_get_cb' from incompatible pointer type [enabled by default]
         SSL_CTX_sess_set_get_cb(ctx,    ssl_callback_GetSessionCacheEntry);
         ^
In file included from ssl_private.h:90:0,
                 from ssl_engine_init.c:29:
/usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:618:6: note: expected 'struct SSL_SESSION * (*)(struct ssl_st *, const unsigned char *, int,  int *)' but argument is of type 'struct SSL_SESSION * (*)(struct SSL *, unsigned char *, int,  int *)'
 void SSL_CTX_sess_set_get_cb(SSL_CTX *ctx,
      ^
ssl_engine_init.c: In function 'use_certificate_chain':
ssl_engine_init.c:861:5: warning: implicit declaration of function 'BIO_s_file_internal' [-Wimplicit-function-declaration]
     if ((bio = BIO_new(BIO_s_file_internal())) == NULL)
     ^
ssl_engine_init.c:861:5: warning: passing argument 1 of 'BIO_new' makes pointer from integer without a cast [enabled by default]
In file included from /usr/local/openssl/openssl-1.1.0/include/openssl/ssl.h:48:0,
                 from ssl_private.h:90,
                 from ssl_engine_init.c:29:
/usr/local/openssl/openssl-1.1.0/include/openssl/bio.h:537:6: note: expected 'const struct BIO_METHOD *' but argument is of type 'int'
 BIO *BIO_new(const BIO_METHOD *type);
      ^
In file included from ssl_private.h:33:0,
                 from ssl_engine_init.c:29:
ssl_engine_init.c: In function 'ssl_init_server_certs':
ssl_engine_init.c:1203:42: error: dereferencing pointer to incomplete type
                      BN_num_bits(dhparams->p), vhost_id, certfile);
                                          ^
/usr/local/src/httpd-2.4.23/include/http_log.h:367:65: note: in definition of macro 'ap_log_error__'
              ap_log_error_(file, line, mi, level, status, sr__, __VA_ARGS__);    \
                                                                 ^
ssl_engine_init.c:1201:9: note: in expansion of macro 'ap_log_error'
         ap_log_error(APLOG_MARK, APLOG_DEBUG, 0, s, APLOGNO(02540)
         ^
make[4]: *** [ssl_engine_init.slo] Error 1
make[4]: Leaving directory `/usr/local/src/httpd-2.4.23/modules/ssl'
make[3]: *** [shared-build-recursive] Error 1
make[3]: Leaving directory `/usr/local/src/httpd-2.4.23/modules/ssl'
make[2]: *** [shared-build-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/httpd-2.4.23/modules'
make[1]: *** [shared-build-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/httpd-2.4.23'


                    ############# ENDLOG ################
Comment 1 Eric Covener 2016-09-10 13:20:47 UTC
Tracked elsewhere, not yet supported. 60061

*** This bug has been marked as a duplicate of bug 60061 ***