Bug 60171 - Report / Dashboard : Active Threads Over Time should stack lines to give the total amount of threads running
Summary: Report / Dashboard : Active Threads Over Time should stack lines to give the ...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 60338 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-24 08:05 UTC by Philippe Mouawad
Modified: 2016-11-03 18:13 UTC (History)
2 users (show)



Attachments
Current graph in a distributed load test where thread groups start with different delays (243.94 KB, image/png)
2016-09-24 08:05 UTC, Philippe Mouawad
Details
Graph in a distributed load test where thread groups start with different delays AFTER the fix (505.30 KB, image/png)
2016-09-24 08:06 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-09-24 08:05:11 UTC
Created attachment 34298 [details]
Current graph in a distributed load test where thread groups start with different delays

Currently this graph shows for each Thread Group the number of threads, so you have to manually sum the threads to know the total number of threads.
This becomes even more annoying when you are in distributed testing as you will see the same serie for every thread group.


See attached screenshot.
Comment 1 Philippe Mouawad 2016-09-24 08:06:15 UTC
Created attachment 34299 [details]
Graph in a distributed load test where thread groups start with different delays AFTER the fix
Comment 2 Philippe Mouawad 2016-09-24 08:18:13 UTC
Author: pmouawad
Date: Sat Sep 24 08:11:19 2016
New Revision: 1762107

URL: http://svn.apache.org/viewvc?rev=1762107&view=rev
Log:
Bug 60171 - Report / Dashboard : Active Threads Over Time should stack lines to give the total amount of threads running
Bugzilla Id: 60171

Added:
    jmeter/trunk/bin/report-template/content/js/jquery.flot.stack.js   (with props)
Modified:
    jmeter/trunk/bin/report-template/content/js/graph.js.fmkr
    jmeter/trunk/bin/report-template/content/pages/OverTime.html.fmkr
    jmeter/trunk/xdocs/changes.xml
    
Author: pmouawad
Date: Sat Sep 24 08:13:28 2016
New Revision: 1762108

URL: http://svn.apache.org/viewvc?rev=1762108&view=rev
Log:
Bug 60171 - Report / Dashboard : Active Threads Over Time should stack lines to give the total amount of threads running
Tab space police !!!!!!

Bugzilla Id: 60171

Modified:
    jmeter/trunk/bin/report-template/content/js/jquery.flot.stack.js   (contents, props changed)
Comment 3 Philippe Mouawad 2016-11-03 18:13:42 UTC
*** Bug 60338 has been marked as a duplicate of this bug. ***