Bug 60287 - Report / Dashboard : Have a new Top5 Errors by sampler table in Dashboard
Summary: Report / Dashboard : Have a new Top5 Errors by sampler table in Dashboard
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 60239 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-20 19:37 UTC by UbikLoadPack support
Modified: 2016-11-12 13:40 UTC (History)
2 users (show)



Attachments
Screenshot of Top 5 Excerpt (360.17 KB, image/png)
2016-10-20 20:10 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description UbikLoadPack support 2016-10-20 19:37:17 UTC
When you analyze a Load Test you frequently search for failure reasons for a particular sampler.

The idea behind this feature is to provide the TOP 5 errors for every sampler in error.
Comment 1 Philippe Mouawad 2016-10-20 20:10:18 UTC
Created attachment 34393 [details]
Screenshot of Top 5 Excerpt
Comment 2 Philippe Mouawad 2016-10-20 20:22:08 UTC
Author: pmouawad
Date: Thu Oct 20 20:07:31 2016
New Revision: 1765870

URL: http://svn.apache.org/viewvc?rev=1765870&view=rev
Log:
Bug 60287 - Report / Dashboard : Have a new Top5 Errors by sampler table in Dashboard
Bugzilla Id: 60287

Added:
    jmeter/trunk/src/core/org/apache/jmeter/report/processor/Top5ErrorsBySamplerConsumer.java   (with props)
    jmeter/trunk/src/core/org/apache/jmeter/report/processor/Top5ErrorsSummaryData.java   (with props)
Modified:
    jmeter/trunk/bin/report-template/content/js/dashboard.js.fmkr
    jmeter/trunk/bin/report-template/index.html.fmkr
    jmeter/trunk/bin/reportgenerator.properties
    jmeter/trunk/src/core/org/apache/jmeter/report/config/ReportGeneratorConfiguration.java
    jmeter/trunk/src/core/org/apache/jmeter/report/dashboard/HtmlTemplateExporter.java
    jmeter/trunk/src/core/org/apache/jmeter/report/dashboard/ReportGenerator.java
    jmeter/trunk/src/core/org/apache/jmeter/report/processor/ErrorsSummaryConsumer.java
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/generating-dashboard.xml
Comment 3 Philippe Mouawad 2016-11-12 13:40:34 UTC
*** Bug 60239 has been marked as a duplicate of this bug. ***