Bug 60311 - XSLFShape draw can not draw a straight line (form)
Summary: XSLFShape draw can not draw a straight line (form)
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: XSLF (show other bugs)
Version: 3.14-FINAL
Hardware: PC Mac OS X 10.1
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-27 10:11 UTC by Konstantin
Modified: 2016-12-28 00:08 UTC (History)
0 users



Attachments
Working line ... (34.47 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-10-28 00:14 UTC, Andreas Beeker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin 2016-10-27 10:11:43 UTC
I was trying to draw a simple straight line. But since wether its horizontally or vertically the height or width is 0. Within the drawShape method the bounds are checked with shapeBounds.isEmpty() and returns. Given that lines cannot be drawn.
Comment 1 Dominik Stadler 2016-10-27 18:44:21 UTC
Can you share some code that demonstrates this? Othwerwise it's very cumbersome to reproduce or comment on it.
Comment 2 Andreas Beeker 2016-10-28 00:14:27 UTC
Created attachment 34406 [details]
Working line ...

The attached PPTX contains the following anchor and PPTX2PNG renderes a transparent background with the black line:
<a:ext cx="4680000" cy="0"/>

So this works for me ...
Comment 3 Andreas Beeker 2016-12-28 00:08:41 UTC
no response for 2 months + works for me -> closed