Bug 60338 - Dashboard does not show correct number of threads where the test plan is executed over two or more remote servers
Summary: Dashboard does not show correct number of threads where the test plan is exec...
Status: VERIFIED DUPLICATE of bug 60171
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-03 16:55 UTC by Anthony Kearns
Modified: 2016-11-03 22:41 UTC (History)
2 users (show)



Attachments
results zip file with results.jtl (860.25 KB, application/x-zip-compressed)
2016-11-03 17:12 UTC, Anthony Kearns
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Kearns 2016-11-03 16:55:39 UTC
I have a test plan which is configured for 35 threads. I run the test plan on two remote servers so the total active threads should be 70. When i look at the thread group related graphs on the dashboard i only see 35 threads being reported. I would expect that the dashboard should show 70 threads.

I have attached my results.jtl file and a screenshot of the thread group related graphs on the dashboard.

Let me know if you need more info....

Maybe this is already addressed by bug 60171 ?
Comment 1 Anthony Kearns 2016-11-03 17:12:46 UTC
Created attachment 34419 [details]
results zip file with results.jtl
Comment 2 Philippe Mouawad 2016-11-03 18:13:42 UTC
Hi,
This is fixed in nightly build but ensure you read the docs because you need to add to thread group something that uniquely identifies thread group per injector.

Feedback is very welcome.
Regards

*** This bug has been marked as a duplicate of bug 60171 ***
Comment 3 Anthony Kearns 2016-11-03 19:10:45 UTC
Hi, I don't really understand this comment.....

"add to thread group something that uniquely identifies thread group per injector."

In my case the test plan has one thread group and the plan is 35 threads. So when the plan is sent to two remote slaves each slave runs 35 threads and hence the total threads is 70 started and 70 active. If is send this results.jtl file to blaze Meter sense site it identifies correctly that there are 70 threads.

Maybe I just need to update the dashboard changes to my jmeter instance to try out the changes?
Comment 4 Philippe Mouawad 2016-11-03 19:21:01 UTC
(In reply to anthony.kearns@ymail.com from comment #3)
> Hi, I don't really understand this comment.....
> 
> "add to thread group something that uniquely identifies thread group per
> injector."
> 
> In my case the test plan has one thread group and the plan is 35 threads. So
> when the plan is sent to two remote slaves each slave runs 35 threads and
> hence the total threads is 70 started and 70 active.

Please read the nightly build doc about how to configure it.
so that it works in jmeter.
You need for example to add ${__machineName} in the thread group name


> If is send this
> results.jtl file to blaze Meter sense site it identifies correctly that
> there are 70 threads.


I don't know how blazemeter works, but JMeter has no relation with it.
If you're running your test within blazemeter then report it to their support.
If it's plain jmeter then follow my advice and give feedback.

Thanks



> Maybe I just need to update the dashboard changes to my jmeter instance to
> try out the changes?
Comment 5 Anthony Kearns 2016-11-03 22:41:56 UTC
Thank you, i get it now. Will close this bug now as a dupe of the one you mentioned.

thanks again