Bug 60358 - Http Request : Allow sending Body Data for HTTP GET request
Summary: Http Request : Allow sending Body Data for HTTP GET request
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 57739 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-10 13:09 UTC by Saumitra
Modified: 2017-02-26 20:15 UTC (History)
3 users (show)



Attachments
Patch fixing the issue (2.16 KB, patch)
2016-11-10 21:47 UTC, Philippe Mouawad
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saumitra 2016-11-10 13:09:40 UTC
HTTP request sampler does not send Body data if HTTP GET call is requested with body data. In other words, there is no way to make HTTP request equivalent to the following cURL
curl -XGET http://host/endpoint -d "request_body"

REST API with Body Data is exposed as a standard API in Elasticsearch https://www.elastic.co/guide/en/elasticsearch/reference/2.3/search-request-body.html and there is no way to test the performance of those APIs with JMeter.
Comment 1 Philippe Mouawad 2016-11-10 21:47:40 UTC
Created attachment 34435 [details]
Patch fixing the issue
Comment 2 Philippe Mouawad 2016-11-12 00:19:38 UTC
Author: pmouawad
Date: Sat Nov 12 00:17:58 2016
New Revision: 1769364

URL: http://svn.apache.org/viewvc?rev=1769364&view=rev
Log:
Bug 60358 - Http Request : Allow sending Body Data for HTTP GET request
Put back the mention of bug delete in r1769202
Update documentation which was wrong for DELETE and update it for GET
Bugzilla Id: 60358

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSampleResult.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 3 Philippe Mouawad 2017-02-26 20:15:19 UTC
*** Bug 57739 has been marked as a duplicate of this bug. ***