Bug 60361 - ModuleController : If a Test plan contains a Module Controller which references an unexistant Controller, JMeter in GUI mode will not stop
Summary: ModuleController : If a Test plan contains a Module Controller which referenc...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 regression (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-10 21:43 UTC by Philippe Mouawad
Modified: 2016-11-10 22:34 UTC (History)
1 user (show)



Attachments
Test plan to reproduce (11.41 KB, application/xml)
2016-11-10 21:43 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-11-10 21:43:21 UTC
Created attachment 34434 [details]
Test plan to reproduce

This bug has been reported on jmeter-fr google group by Jean-Marie Markowski.

Attached a Test Plan, open GUI, load this plan , run test.
An exception is thrown in logs and it's impossible to stop test unless you quit JMeter.

This BUG is a blocker for me and should be fixed before 3.1 release.
Comment 1 Philippe Mouawad 2016-11-10 22:22:01 UTC
This bug is due to Bug 59076
Comment 2 Philippe Mouawad 2016-11-10 22:34:22 UTC
Author: pmouawad
Date: Thu Nov 10 22:33:31 2016
New Revision: 1769218

URL: http://svn.apache.org/viewvc?rev=1769218&view=rev
Log:
Bug 60361 - ModuleController : If a Test plan contains a Module Controller which references an unexistant Controller, JMeter in GUI mode will not stop
Bugzilla Id: 60361

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/engine/StandardJMeterEngine.java


Author: pmouawad
Date: Thu Nov 10 22:23:16 2016
New Revision: 1769215

URL: http://svn.apache.org/viewvc?rev=1769215&view=rev
Log:
Bug 60361 - ModuleController : If a Test plan contains a Module Controller which references an unexistant Controller, JMeter in GUI mode will not stop
Bugzilla Id: 60361

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/control/ModuleController.java
    jmeter/trunk/xdocs/changes.xml