Bug 60376 - Http Test Script Recorder : If deflate is used by server then recording may break application
Summary: Http Test Script Recorder : If deflate is used by server then recording may b...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.0
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-15 16:56 UTC by Philippe Mouawad
Modified: 2016-11-16 07:29 UTC (History)
1 user (show)



Attachments
Patch fixing issue (1.85 KB, patch)
2016-11-15 18:45 UTC, Philippe Mouawad
Details | Diff
Headers seen from browser (956 bytes, text/plain)
2016-11-15 19:46 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-11-15 16:56:35 UTC
Hello,
The issue is the following.
I have an application that uses deflate compression.

I start recorder, I configure Firefox so that JMeter record.
I access application, I get a page saying "Error on content encoding" (translation of french message "Erreur d'encodage de contenu").

If I remove deflate from firefox in about:config and keep only gzip, network.http.accept-encoding=gzip

It works.

The bug is in JMeter Test script recorder.

It is a pretty nasty bug and it may block a lot of users facing it who would think JMeter is not able to record their application.

I must confess I found the workaround by chance.

Regards 
Philippe
Comment 1 Philippe Mouawad 2016-11-15 18:45:34 UTC
Created attachment 34449 [details]
Patch fixing issue
Comment 2 Philippe Mouawad 2016-11-15 19:46:57 UTC
Created attachment 34450 [details]
Headers seen from browser
Comment 3 Philippe Mouawad 2016-11-16 07:27:36 UTC
After further tests, this does not break all applications using Deflate.
Comment 4 Philippe Mouawad 2016-11-16 07:29:02 UTC
Author: pmouawad
Date: Wed Nov 16 07:28:45 2016
New Revision: 1769932

URL: http://svn.apache.org/viewvc?rev=1769932&view=rev
Log:
Bug 60376 - Http Test Script Recorder : If deflate is used by server then recording may break application
Bugzilla Id: 60376

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/proxy/Proxy.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/HTTPConstantsInterface.java
    jmeter/trunk/xdocs/changes.xml