Bug 60527 - java.lang.NoSuchMethodError: org.apache.poi.util.POILogger.log(I[Ljava/lang/Object;)V : when working with Eclipse Java EE developer neon version.
Summary: java.lang.NoSuchMethodError: org.apache.poi.util.POILogger.log(I[Ljava/lang/O...
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: 3.16-dev
Hardware: PC Linux
: P2 blocker (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-29 05:33 UTC by Swedha B
Modified: 2016-12-29 09:21 UTC (History)
0 users



Attachments
This is the error that I got when I run the Apache tomcat server Version 7.0.73 (210.16 KB, image/png)
2016-12-29 05:33 UTC, Swedha B
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Swedha B 2016-12-29 05:33:31 UTC
Created attachment 34564 [details]
This is the error that I got when I run the Apache tomcat server Version 7.0.73

I tried using poi-3.16-beta1 version. I included this poi into /usr/share/poi-3.16-beta1 directory and also bulid the java path into my project. And now doing this in Eclipse Java EE developer neon version.
Comment 1 Dominik Stadler 2016-12-29 08:51:29 UTC
Did you check the discussion at http://stackoverflow.com/questions/33415904/apache-poi-parsing-error, it suggests to ensure that all poi-jars are from one version and no transitive dependency drags in some outdated jar-file which does not have the method that is seen here. I.e. poi-scratchpad seems to be newer than the main poi-jar-file.

There was a somewhat related discussion in bug 59933, but that looked a bit different and is fixed in 3.16-beta1.
Comment 2 Swedha B 2016-12-29 09:06:12 UTC
(In reply to Dominik Stadler from comment #1)
> Did you check the discussion at
> http://stackoverflow.com/questions/33415904/apache-poi-parsing-error, it
> suggests to ensure that all poi-jars are from one version and no transitive
> dependency drags in some outdated jar-file which does not have the method
> that is seen here. I.e. poi-scratchpad seems to be newer than the main
> poi-jar-file.
> 
> There was a somewhat related discussion in bug 59933, but that looked a bit
> different and is fixed in 3.16-beta1.


I saw this link that you have mentioned. I have now included poi-3.13 beta version and poi-3.16 version. So, you mean I have to only use poi-3.16 or poi-3.13.
Comment 3 Swedha B 2016-12-29 09:21:00 UTC
(In reply to Dominik Stadler from comment #1)
> Did you check the discussion at
> http://stackoverflow.com/questions/33415904/apache-poi-parsing-error, it
> suggests to ensure that all poi-jars are from one version and no transitive
> dependency drags in some outdated jar-file which does not have the method
> that is seen here. I.e. poi-scratchpad seems to be newer than the main
> poi-jar-file.
> 
> There was a somewhat related discussion in bug 59933, but that looked a bit
> different and is fixed in 3.16-beta1.


This problem solved. I given only 1 version poi-3.16 beta1 version. I am able to fix the problem. Intially I did this. But didn't worked for me. After reporting here I "reinstalled" the Eclipse and now when I repeat this the error gone. Thanks alot :)