Bug 60581 - tomcat8 at 100% cpu when trying https on port 80
Summary: tomcat8 at 100% cpu when trying https on port 80
Status: RESOLVED DUPLICATE of bug 57544
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Connectors (show other bugs)
Version: 8.0.14
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
Depends on:
Reported: 2017-01-12 16:19 UTC by cooltg66+ASF_Bugzilla
Modified: 2017-01-25 08:41 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description cooltg66+ASF_Bugzilla 2017-01-12 16:19:15 UTC
When trying to connect to tomcat 8 using https://localhost:8080/ tomcat get stuck at 100% cpu with 
ip - - [12/Jan/2017:12:14:23 +0100] "-" 400 - -
in the access_log and

Jan 12, 2017 1:23:50 PM org.apache.coyote.http11.AbstractHttp11Processor process
INFO: Error parsing HTTP request header
 Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.

in catalina.out

I know I shouldn't try https on port 8080 or 80 but I get those requests on my server and I have to restart tomcat to fix the 100% cpu utilization problem.

I'm using the default configuration from debian 8:

    <Connector port="8080" protocol="HTTP/1.1"
               redirectPort="8443" />
Comment 1 Mark Thomas 2017-01-12 17:34:54 UTC

*** This bug has been marked as a duplicate of bug 57544 ***
Comment 2 Ralf Hauser 2017-01-25 08:33:29 UTC
Could that be related?
Comment 3 Emmanuel Bourg 2017-01-25 08:41:23 UTC
Yes it looks like the same issue. The best solution for now is to install the tomcat8 package from the jessie-backports repository.