Bug 60621 - The "report-template" folder is missing from ApacheJMeter_config-3.1.jar in maven central
Summary: The "report-template" folder is missing from ApacheJMeter_config-3.1.jar in m...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.1
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-21 15:25 UTC by Mark Collin
Modified: 2017-01-22 20:15 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Collin 2017-01-21 15:25:49 UTC
The "report-template" folder is missing from ApacheJMeter_config-3.1.jar.

This means that things that depend upon the maven dependencies for JMeter cannot use the new dashboard reports as detailed here:

http://jmeter.apache.org/usermanual/generating-dashboard.html

The error you get when trying to run Jmeter with the maven dependencies is:

2017/01/21 12:02:03 ERROR - jmeter.report.dashboard.ReportGenerator: Data exporter "html" is unable to export data. org.apache.jmeter.report.dashboard.ExportException: "/Users/fyre/Programming/jmeter-maven-plugin/target/it/multiple-tests-generate-reports/target/jmeter/bin/report-template" is not a valid template directory
	at org.apache.jmeter.report.dashboard.HtmlTemplateExporter.export(HtmlTemplateExporter.java:353)
	at org.apache.jmeter.report.dashboard.ReportGenerator.exportData(ReportGenerator.java:388)
	at org.apache.jmeter.report.dashboard.ReportGenerator.generate(ReportGenerator.java:264)
	at org.apache.jmeter.JMeter$ListenToTest.generateReport(JMeter.java:1152)
	at org.apache.jmeter.JMeter$ListenToTest.testEnded(JMeter.java:1091)
	at org.apache.jmeter.engine.StandardJMeterEngine.notifyTestListenersOfEnd(StandardJMeterEngine.java:216)
	at org.apache.jmeter.engine.StandardJMeterEngine.run(StandardJMeterEngine.java:437)
	at java.lang.Thread.run(Thread.java:745)

2017/01/21 12:02:03 ERROR - jmeter.JMeter: Error generating dashboard:Data exporter "html" is unable to export data. org.apache.jmeter.report.dashboard.GenerationException: Data exporter "html" is unable to export data.
	at org.apache.jmeter.report.dashboard.ReportGenerator.exportData(ReportGenerator.java:397)
	at org.apache.jmeter.report.dashboard.ReportGenerator.generate(ReportGenerator.java:264)
	at org.apache.jmeter.JMeter$ListenToTest.generateReport(JMeter.java:1152)
	at org.apache.jmeter.JMeter$ListenToTest.testEnded(JMeter.java:1091)
	at org.apache.jmeter.engine.StandardJMeterEngine.notifyTestListenersOfEnd(StandardJMeterEngine.java:216)
	at org.apache.jmeter.engine.StandardJMeterEngine.run(StandardJMeterEngine.java:437)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.jmeter.report.dashboard.ExportException: "/Users/fyre/Programming/jmeter-maven-plugin/target/it/multiple-tests-generate-reports/target/jmeter/bin/report-template" is not a valid template directory
	at org.apache.jmeter.report.dashboard.HtmlTemplateExporter.export(HtmlTemplateExporter.java:353)
	at org.apache.jmeter.report.dashboard.ReportGenerator.exportData(ReportGenerator.java:388)
	... 6 more
Comment 1 Philippe Mouawad 2017-01-21 22:02:53 UTC
Author: pmouawad
Date: Sat Jan 21 22:02:34 2017
New Revision: 1779759

URL: http://svn.apache.org/viewvc?rev=1779759&view=rev
Log:
Bug 60621 - The "report-template" folder is missing from ApacheJMeter_config-3.1.jar in maven central
Bugzilla Id: 60621

Modified:
    jmeter/trunk/build.xml
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2017-01-21 22:03:12 UTC
Hello Mark,
Can you test if it's ok for you ?
Thanks
Comment 3 Mark Collin 2017-01-22 19:40:23 UTC
I'm having a few problems because https://repository.apache.org/content/groups/snapshots/org/apache/jmeter/ApacheJMeter_monitors/ does not appear to have a 3.2 version.

Is this being removed in 3.2?
Comment 4 Mark Collin 2017-01-22 19:44:37 UTC
It looks like the "report-template" folder is still not there:

kezef:jmeter-maven-plugin-example fyre$ jar -tf ~/Downloads/ApacheJMeter_config-3.2-20170120.021703-50.jar 
META-INF/
META-INF/MANIFEST.MF
META-INF/NOTICE
META-INF/LICENSE
bin/
bin/BeanShellAssertion.bshrc
bin/BeanShellFunction.bshrc
bin/BeanShellListeners.bshrc
bin/BeanShellSampler.bshrc
bin/hc.parameters
bin/httpclient.parameters
bin/jmeter.properties
bin/reportgenerator.properties
bin/saveservice.properties
bin/system.properties
bin/upgrade.properties
bin/user.properties
bin/jaas.conf
bin/krb5.conf
bin/log4j.conf
bin/logkit.xml
Comment 5 Philippe Mouawad 2017-01-22 19:47:32 UTC
(In reply to Mark Collin from comment #3)
> I'm having a few problems because
> https://repository.apache.org/content/groups/snapshots/org/apache/jmeter/
> ApacheJMeter_monitors/ does not appear to have a 3.2 version.
> 
> Is this being removed in 3.2?

Yes, you can read changes.xml
Comment 6 Philippe Mouawad 2017-01-22 19:48:46 UTC
(In reply to Philippe Mouawad from comment #5)
> (In reply to Mark Collin from comment #3)
> > I'm having a few problems because
> > https://repository.apache.org/content/groups/snapshots/org/apache/jmeter/
> > ApacheJMeter_monitors/ does not appear to have a 3.2 version.
> > 
> > Is this being removed in 3.2?
> 
> Yes, you can read changes.xml
(In reply to Mark Collin from comment #4)
> It looks like the "report-template" folder is still not there:
> 
> kezef:jmeter-maven-plugin-example fyre$ jar -tf
> ~/Downloads/ApacheJMeter_config-3.2-20170120.021703-50.jar 
> META-INF/
> META-INF/MANIFEST.MF
> META-INF/NOTICE
> META-INF/LICENSE
> bin/
> bin/BeanShellAssertion.bshrc
> bin/BeanShellFunction.bshrc
> bin/BeanShellListeners.bshrc
> bin/BeanShellSampler.bshrc
> bin/hc.parameters
> bin/httpclient.parameters
> bin/jmeter.properties
> bin/reportgenerator.properties
> bin/saveservice.properties
> bin/system.properties
> bin/upgrade.properties
> bin/user.properties
> bin/jaas.conf
> bin/krb5.conf
> bin/log4j.conf
> bin/logkit.xml


Hi,
I fixed it yesterday, so it is not in this snapshot.
But in:
ApacheJMeter_config-3.2-20170122.021718-52.jar

Regards
Comment 7 Mark Collin 2017-01-22 20:10:34 UTC
Looks like I should stay off the Cider when looking at bugs :)

Yes this the correct files are now in the jar, and when I remove the dependency on ApacheJMeter_monitors everything runs correctly.
Comment 8 Philippe Mouawad 2017-01-22 20:15:28 UTC
(In reply to Mark Collin from comment #7)
> Looks like I should stay off the Cider when looking at bugs :)

cider or beer :-) ?

> 
> Yes this the correct files are now in the jar, and when I remove the
> dependency on ApacheJMeter_monitors everything runs correctly.

Are you preparing for 3.2 release ?