Bug 60653 - remove or make optional output of comment
Summary: remove or make optional output of comment
Status: RESOLVED DUPLICATE of bug 60613
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Jasper (show other bugs)
Version: 8.5.9
Hardware: PC All
: P2 enhancement (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-26 19:35 UTC by bmisek
Modified: 2017-01-27 10:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bmisek 2017-01-26 19:35:47 UTC
In Generator.java when generating the setters, it outputs a comment for each one. This line:

out.printil("// "+m.getFile()+"("+m.getLineNumber()+","+m.getColumnNumber()+") "+ attrs[i].getTagAttributeInfo());

Can either remove this comment output or make it some type of optional debug setting?  We've got a scenario with some custom tags that causes really large generated code and much of it is comments due to this line.

thanks.
Comment 1 Mark Thomas 2017-01-27 10:05:44 UTC
Comments have no impact on the size of the generated class file.

This appears to be a duplicate of the issues raised after the try/finally clean-up fixes.

*** This bug has been marked as a duplicate of bug 60613 ***