Bug 60754 - When docx.close(),docx.write(os) will report a Rule M2.4 exception
Summary: When docx.close(),docx.write(os) will report a Rule M2.4 exception
Status: RESOLVED DUPLICATE of bug 59634
Alias: None
Product: POI
Classification: Unclassified
Component: XWPF (show other bugs)
Version: 3.14-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-21 06:37 UTC by Lyn
Modified: 2017-02-21 13:56 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lyn 2017-02-21 06:37:22 UTC
docx.close();

bla...bla...

docx.write(os);
Comment 1 Dominik Stadler 2017-02-21 13:56:08 UTC
So please stick to the doc and do not close the document until you are done writing it.

See bug 59678 and 59634 for the previous discussion on this topic.

*** This bug has been marked as a duplicate of bug 59634 ***