Bug 60782 - HTTP Request : Parameters are ignored in PUT requests
Summary: HTTP Request : Parameters are ignored in PUT requests
Status: RESOLVED DUPLICATE of bug 43612
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.1
Hardware: All All
: P2 normal with 2 votes (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-27 23:23 UTC by Philippe Mouawad
Modified: 2018-04-02 12:20 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2017-02-27 23:23:29 UTC
Currently when you set this in HTTP REquest:

Method : PUT
Path: /test?name0=value0
Send Parameters with Request : name1 in Name: column / value1 in Value

JMeter emits :
PUT http://localhost:8081/test?name0=value0

Ignoring Send Parameters with Request content.
Comment 1 Raul 2017-06-14 15:50:44 UTC
This bug is also with Method PATCH:

PATCH http://localhost:8080/rest/customers/1836

PATCH data:


[no cookies]
Comment 2 danceric 2017-07-17 08:03:41 UTC
same issue encountered 
is there anyone trying to fix this bug currently?
or if anyone have alternative way to solve this issue?
thanks.
Comment 3 danceric 2017-07-17 08:07:07 UTC
(In reply to danceric from comment #2)
> same issue encountered 
> is there anyone trying to fix this bug currently?
> or if anyone have alternative way to solve this issue?
> thanks.

BTW, I'm using 3.2 r1790748 build
Comment 4 Philippe Mouawad 2018-04-02 12:20:25 UTC

*** This bug has been marked as a duplicate of bug 43612 ***