Bug 60800 - Content type charset in Request Headers
Summary: Content type charset in Request Headers
Status: RESOLVED DUPLICATE of bug 61384
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.1
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-02 08:47 UTC by Hemachandar
Modified: 2017-08-27 12:43 UTC (History)
2 users (show)



Attachments
Jmeter - v2.9 (18.74 KB, image/png)
2017-03-02 08:47 UTC, Hemachandar
Details
Jmeter - v3.1 (27.36 KB, image/png)
2017-03-02 08:48 UTC, Hemachandar
Details
http request (27.60 KB, image/png)
2017-03-02 09:09 UTC, Hemachandar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hemachandar 2017-03-02 08:47:55 UTC
Created attachment 34791 [details]
Jmeter - v2.9

I am trying to upload a file to a dbserver. As per my request format everything is working fine. But there is an issue in HTTP Request Headers. I have added common http headers through the request. But Content-Type is added additionally through the request header. 

The actual problem arises when reading the boundary value. JMeter additionally share charset in the content-type which is not actually needed for request headers.

This was faced in version 3.1. But in Jmeter 2.9 there is no charset shared in the request headers and it is processing successfully. 

Please let me know how to disable the charset in content type for HTTP request headers.

Attaching the screenshot of Request headers for v3.1 and v2.9.
Comment 1 Hemachandar 2017-03-02 08:48:54 UTC
Created attachment 34792 [details]
Jmeter - v3.1

Jmeter - v3.1
Comment 2 UbikLoadPack support 2017-03-02 08:59:23 UTC
Hello,
Can you show how your HttpRequest is configured ?
Possibly attaching a short JMX plan instead of screenshot ?
Thanks
Comment 3 Hemachandar 2017-03-02 09:09:12 UTC
Created attachment 34793 [details]
http request
Comment 4 Philippe Mouawad 2017-08-27 12:29:39 UTC

*** This bug has been marked as a duplicate of bug 61384 ***
Comment 5 Philippe Mouawad 2017-08-27 12:43:02 UTC
Hello @Hemachandar, 
Can you test nightly build tomorrow and report wether this bug is fixed for you ?

- http://jmeter.apache.org/nightly.html

Thanks