Bug 60980 - FormulaParser does not parse intersections of named ranges
Summary: FormulaParser does not parse intersections of named ranges
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: SS Common (show other bugs)
Version: 3.15-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 60235 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-13 11:56 UTC by Efthimia
Modified: 2019-02-24 12:56 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Efthimia 2017-04-13 11:56:39 UTC
When attempting to parse valid Excel formula SUM(fenia fenia3) with apache.poi.ss.formula.FormulaParser.parse, it throws exception:

org.apache.poi.ss.formula.FormulaParseException: Parse error near char 10 'f' in specified formula 'SUM(fenia fenia3)'. Expected ',' or ')'

fenia and fenia3 in the formula are defined named ranges
Comment 1 Yegor Kozlov 2019-02-21 17:10:29 UTC
Fixed in r1854037, junit added.

Yegor
Comment 2 Yegor Kozlov 2019-02-24 12:56:25 UTC
*** Bug 60235 has been marked as a duplicate of this bug. ***