Bug 60995 - HTTP Test Script Recorder : Port field is very small under some Windows LAF
Summary: HTTP Test Script Recorder : Port field is very small under some Windows LAF
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.2
Hardware: PC All
: P3 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 61073 61099 61177 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-16 04:56 UTC by navneetkrishnam
Modified: 2017-06-12 05:12 UTC (History)
5 users (show)



Attachments
Screenshot of bug (54.09 KB, image/png)
2017-04-16 04:56 UTC, navneetkrishnam
Details
New Panel with GTK+ on XWayland without HiDPI settings (61.27 KB, image/png)
2017-05-05 07:43 UTC, Milamber
Details
New Panel with CrossPlatform L&F on XWayland with HiDPI settings (49.16 KB, image/png)
2017-05-05 07:44 UTC, Milamber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description navneetkrishnam 2017-04-16 04:56:12 UTC
Created attachment 34916 [details]
Screenshot of bug

The Port box is very small and makes it difficult to view or modify the listening port.

My system configuration are as below:

1. OS: Windows 10
2. Bit: 64 bit
3. Java version: 1.8.0_66 - 64 bit version

Steps to reproduce the bug:
Right click on Workbench and add HTTP(S) Test Script Recorder
Comment 1 Philippe Mouawad 2017-04-19 20:07:48 UTC
Hi Team,
I'm not able to reproduce this issue under my Windows versions and on Mac.
So if anybody can work on it.

Thanks
Comment 2 Felix Schumacher 2017-04-20 18:53:17 UTC
I can reproduce it with linux under gnome and with and the system (gtk+) LAF.
I had to start JMeter with system LAF, to show the described behaviour and as soon as I switched to crossplatform LAF, the port-field had the correct width.
Comment 3 Felix Schumacher 2017-04-30 10:02:32 UTC
I have fixed this for gnome system LAF. I hope, it fixes the affected windows LAF, too.

@naveetkrishnam, could you please test the next nightly, to see if it fixes your problem?

This fix will be included in version 3.3.

Date: Sun Apr 30 10:00:12 2017
New Revision: 1793255

URL: http://svn.apache.org/viewvc?rev=1793255&view=rev
Log:
HTTP Test Script Recorder: Port field is very small under some LAF

Bugzilla Id: 60995

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/proxy/gui/ProxyControlGui.java
    jmeter/trunk/xdocs/changes.xml
Comment 4 navneetkrishnam 2017-05-02 06:26:26 UTC
Hi. I tested the nightly build "apache-jmeter-r1792334". However, the issue persists in the "Nimbus" look and feel.
Comment 5 Milamber 2017-05-05 07:29:49 UTC
*** Bug 61073 has been marked as a duplicate of this bug. ***
Comment 6 Milamber 2017-05-05 07:42:31 UTC
Fixed on Linux, but probably on Windows too, please re-open if not fixed on Windows. 

See new screenshot

URL: http://svn.apache.org/viewvc?rev=1793967&view=rev
Log:
HTTP Test Script Recorder : Port field is very small under some Windows LAF
HTTP(S) Test Script Recorder panel have some fields with bad size on HiDPI screen or GTK+ L&F on Linux/XWayland
Not needed to use the MinimumSize or PreferredSize for UI panel/components, let's the UI manager set the good dimension depending the L&F settings
Using the icon size settings for images on control panel

Bugzilla Id: 60995

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/proxy/gui/ProxyControlGui.java
    jmeter/trunk/xdocs/changes.xml
Comment 7 Milamber 2017-05-05 07:43:40 UTC
Created attachment 34978 [details]
New Panel with GTK+ on XWayland without HiDPI settings
Comment 8 Milamber 2017-05-05 07:44:18 UTC
Created attachment 34979 [details]
New Panel with CrossPlatform L&F on XWayland with HiDPI settings
Comment 9 Felix Schumacher 2017-05-15 21:07:14 UTC
*** Bug 61099 has been marked as a duplicate of this bug. ***
Comment 10 Felix Schumacher 2017-06-12 05:12:27 UTC
*** Bug 61177 has been marked as a duplicate of this bug. ***