Bug 61029 - The XSSF setCellValue with Unicode character produces a corrupt workbook
Summary: The XSSF setCellValue with Unicode character produces a corrupt workbook
Status: RESOLVED DUPLICATE of bug 54084
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.15-FINAL
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 61030 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-24 06:07 UTC by gauss.gao
Modified: 2017-05-27 21:00 UTC (History)
0 users



Attachments
the examples java file & result (47.18 KB, application/x-zip-compressed)
2017-04-25 03:01 UTC, gauss.gao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gauss.gao 2017-04-24 06:07:21 UTC
The XSSF can't setcellvalue right to excel file when the world is "𤯥";
The HSSF would work good even if the world id "𤯥", but, Once I export file by using XSSF, the world was an unreadable world "??".

Here is some information that may helpfull:

1."𤯥" unicode:\ud852\udfe5
2."𤯥" Hexadecimal:F0 A4 AF A5
Comment 1 Javen O'Neal 2017-04-24 07:47:45 UTC
*** Bug 61030 has been marked as a duplicate of this bug. ***
Comment 2 Javen O'Neal 2017-04-24 07:52:42 UTC
POI has been used successfully with non-ASCII Unicode characters before, including version 3.15.

Can you include a code snippet so that we can reproduce the problem? What version of Excel are you using?
Comment 3 gauss.gao 2017-04-25 03:01:18 UTC
Created attachment 34948 [details]
the examples java file & result

Thank you for your kind reply.I have upload a zip file which include code & two pic.I will provide the all information what u need, thank u.
Comment 4 gauss.gao 2017-04-25 03:06:02 UTC
I run the code on win/linux , open file with excel2007/excel2010/excel2013.
Comment 5 Dominik Stadler 2017-05-27 21:00:03 UTC
This seems to be a duplicate of bug 54084, unfortunately this happens deep inside XmlBeans for some Unicode characters, likely the ones that require more than 2 bytes in UTF-8 (not sure what the actual Unicode-spec-term is here...).

*** This bug has been marked as a duplicate of bug 54084 ***