Bug 61056 - HTTP : Support brotli decoding
Summary: HTTP : Support brotli decoding
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.2
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-30 20:32 UTC by Philippe Mouawad
Modified: 2018-04-25 13:51 UTC (History)
1 user (show)



Attachments
Test plan used to test feature (11.35 KB, application/xml)
2017-04-30 21:25 UTC, Philippe Mouawad
Details
Jmeter 3.3 or Jmeter 4 - still don't support Brotli (98.91 KB, image/png)
2018-04-25 12:47 UTC, alexandra.zhmurko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2017-04-30 20:32:33 UTC
Brotli is a new compression algorithm that improves compression and performances:

- https://www.keycdn.com/blog/keycdn-brotli-support/

This enhancement will add its support to JMeter relying on:

- https://github.com/google/brotli/tree/master/java/org/brotli
Comment 1 Philippe Mouawad 2017-04-30 20:49:19 UTC
Author: pmouawad
Date: Sun Apr 30 20:47:57 2017
New Revision: 1793277

URL: http://svn.apache.org/viewvc?rev=1793277&view=rev
Log:
Bug 61056 - HTTP : Support brotli decoding
Fix tests failure
Bugzilla Id: 61056

Modified:
    jmeter/trunk/build.properties
    jmeter/trunk/build.xml
    jmeter/trunk/eclipse.classpath
    
Author: pmouawad
Date: Sun Apr 30 20:41:59 2017
New Revision: 1793276

URL: http://svn.apache.org/viewvc?rev=1793276&view=rev
Log:
Bug 61056 - HTTP : Support brotli decoding
Bugzilla Id: 61056

Added:
    jmeter/trunk/licenses/bin/dec-0.1.1.txt   (with props)
Modified:
    jmeter/trunk/build.properties
    jmeter/trunk/build.xml
    jmeter/trunk/lib/   (props changed)
    jmeter/trunk/lib/aareadme.txt
    jmeter/trunk/res/maven/ApacheJMeter_parent.pom
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2017-04-30 21:25:47 UTC
Created attachment 34965 [details]
Test plan used to test feature
Comment 3 alexandra.zhmurko 2018-04-25 12:47:29 UTC
Created attachment 35892 [details]
Jmeter 3.3 or Jmeter 4 - still don't support Brotli
Comment 4 Philippe Mouawad 2018-04-25 12:55:37 UTC
(In reply to alexandra.zhmurko from comment #3)
> Created attachment 35892 [details]
> Jmeter 3.3 or Jmeter 4 - still don't support Brotli

Can you give us access to application please ?
Thank you
Comment 5 alexandra.zhmurko 2018-04-25 13:26:14 UTC
Note, that Brotli compression still doesn't work with Java implementation. Only with HttpClient4 Client Implementation
Comment 6 alexandra.zhmurko 2018-04-25 13:34:41 UTC
(In reply to Philippe Mouawad from comment #4)
> (In reply to alexandra.zhmurko from comment #3)
> > Created attachment 35892 [details]
> > Jmeter 3.3 or Jmeter 4 - still don't support Brotli
> 
> Can you give us access to application please ?
> Thank you

I already found the reason. It's all because of Client implementation type. Works fine for HttpClient4
Thanks
Comment 7 Philippe Mouawad 2018-04-25 13:51:47 UTC
(In reply to alexandra.zhmurko from comment #6)
> (In reply to Philippe Mouawad from comment #4)
> > (In reply to alexandra.zhmurko from comment #3)
> > > Created attachment 35892 [details]
> > > Jmeter 3.3 or Jmeter 4 - still don't support Brotli
> > 
> > Can you give us access to application please ?
> > Thank you
> 
> I already found the reason. It's all because of Client implementation type.
> Works fine for HttpClient4
> Thanks

Brotli only works with HC4. It"s not a bug , it's a limitation.

Can we consider there is no bug ?
Thanks