Bug 61071 - Median calculation : Document algorithm used
Summary: Median calculation : Document algorithm used
Status: RESOLVED DUPLICATE of bug 61130
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.6
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-05 03:56 UTC by Aleksei Balan
Modified: 2017-09-02 19:35 UTC (History)
1 user (show)



Attachments
aggregate report csv file (339 bytes, text/plain)
2017-05-05 03:56 UTC, Aleksei Balan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksei Balan 2017-05-05 03:56:18 UTC
Created attachment 34975 [details]
aggregate report csv file

For even number of tests median should be the mean of the two middle values.
JMeter 3.2 calculate median as 50% line and this is wrong approach.

For example, aggregate report data:
Samples: 2
Min: 197
Max: 252
Average: 224
Median: 197

Here for 2 samples median should be the same as average (224) but it is the same as min (197) and this is incorrect.
Comment 1 Philippe Mouawad 2017-05-25 14:46:16 UTC
Hi Team,
What shall we do with that ?
It appears it's all a matter of different possible algorithms.

Regards
Comment 2 Philippe Mouawad 2017-05-27 22:47:40 UTC
It appears issue is not bug.
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201705.mbox/%3C96b69e93f3e23098636fa16e3be50e7f%40internetallee.de%3E

*** This bug has been marked as a duplicate of bug 61130 ***
Comment 3 Philippe Mouawad 2017-09-02 19:35:10 UTC

*** This bug has been marked as a duplicate of bug 61130 ***