Bug 61078 - Percentile calculation : Document algorithm used
Summary: Percentile calculation : Document algorithm used
Status: RESOLVED DUPLICATE of bug 61130
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.6
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-06 15:47 UTC by Aleksei Balan
Modified: 2017-09-02 19:35 UTC (History)
1 user (show)



Attachments
TestStatCalculatorPercentile.java (2.10 KB, text/plain)
2017-05-06 15:47 UTC, Aleksei Balan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksei Balan 2017-05-06 15:47:48 UTC
Created attachment 34984 [details]
TestStatCalculatorPercentile.java

The percentile nearest rank method implemented in JMeter have an error and failing on the data from Wikipedia examples.
https://en.wikipedia.org/wiki/Percentile#The_Nearest_Rank_method

Tests implemented
https://gist.github.com/abalanonline/9b128faa67e2459b765c1ef56454684b
Comment 1 Philippe Mouawad 2017-05-27 22:48:02 UTC
It appears issue is not bug.
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201705.mbox/%3C96b69e93f3e23098636fa16e3be50e7f%40internetallee.de%3E

*** This bug has been marked as a duplicate of bug 61130 ***
Comment 2 Philippe Mouawad 2017-09-02 19:35:03 UTC

*** This bug has been marked as a duplicate of bug 61130 ***