Bug 61133 - Incorrect default implementation in CookieManager
Summary: Incorrect default implementation in CookieManager
Status: RESOLVED DUPLICATE of bug 61135
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.2
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-30 08:32 UTC by Artem Fedorov
Modified: 2017-05-30 21:47 UTC (History)
2 users (show)



Attachments
Test plan that reproduces this bug (5.40 KB, application/xml)
2017-05-30 08:32 UTC, Artem Fedorov
Details
Patch to fix this problem (2.11 KB, patch)
2017-05-30 08:47 UTC, Artem Fedorov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Fedorov 2017-05-30 08:32:21 UTC
Created attachment 35012 [details]
Test plan that reproduces this bug

After fixed https://bz.apache.org/bugzilla/show_bug.cgi?id=60727 you didn't change the default implementation of CookieHandler in 
 org.apache.jmeter.protocol.http.control.CookieManager#DEFAULT_IMPLEMENTATION field.  If run
Comment 1 Artem Fedorov 2017-05-30 08:39:01 UTC
...If run attached test plan in non-gui mode it generate error sample, because JMeter try to find HC3CookieHandler class that was dropped. 

I think CookieManager#DEFAULT_IMPLEMENTATION  should refer to CookiePanel#DEFAULT_IMPLEMENTATION.
Comment 2 Artem Fedorov 2017-05-30 08:47:25 UTC
Created attachment 35013 [details]
Patch to fix this problem

I created a patch that solves this problem
Comment 3 Philippe Mouawad 2017-05-30 21:47:06 UTC
Resolved within Bug 61135

*** This bug has been marked as a duplicate of bug 61135 ***