Bug 61159 - Unable to Install Apache httpd Load Balancer. 'make install' failes at ssl_engine_init.c:62:18: error: dereferencing pointer to incomplete type
Summary: Unable to Install Apache httpd Load Balancer. 'make install' failes at ssl_en...
Status: RESOLVED INVALID
Alias: None
Product: Apache httpd-test
Classification: Unclassified
Component: framework (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 blocker
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-06 10:52 UTC by Pavan
Modified: 2017-06-06 11:08 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavan 2017-06-06 10:52:33 UTC
Hello Apache Team,

I am installing Apache httpd 2.2.23 or httpd 2.2.25 from the source code. I have installed all the prerequisites. Openssl I have installed with OpenSSL-1.1.0e.

When i try to install the httpd using "make install" i get the following error:

[root@apache httpd-2.4.23]# ./configure --prefix=/usr/local/apache2  --with-ssl=/usr/local/openssl

The above command succeeded.

make & make install failed.

Could you please help ?

/usr/local/apr/build-1/libtool --silent --mode=compile gcc -std=gnu99 -I/usr/local/openssl/include   -g -O2 -pthread      -DLINUX -D_REENTRANT -D_GNU_SOURCE     -I. -I/root/httpd-2.4.23/os/unix -I/                                        root/httpd-2.4.23/include -I/usr/local/apr/include/apr-1 -I/root/httpd-2.4.23/modules/aaa -I/root/httpd-2.4.23/modules/cache -I/root/httpd-2.4.23/modules/core -I/root/httpd-2.4.23/modules/database                                         -I/root/httpd-2.4.23/modules/filters -I/root/httpd-2.4.23/modules/ldap -I/root/httpd-2.4.23/modules/loggers -I/root/httpd-2.4.23/modules/lua -I/root/httpd-2.4.23/modules/proxy -I/root/httpd-2.4.23/                                        modules/session -I/root/httpd-2.4.23/modules/ssl -I/root/httpd-2.4.23/modules/test -I/root/httpd-2.4.23/server -I/root/httpd-2.4.23/modules/arch/unix -I/root/httpd-2.4.23/modules/dav/main -I/root/h                                        ttpd-2.4.23/modules/generators -I/root/httpd-2.4.23/modules/mappers -prefer-pic -c ssl_engine_config.c && touch ssl_engine_config.slo
/usr/local/apr/build-1/libtool --silent --mode=compile gcc -std=gnu99 -I/usr/local/openssl/include   -g -O2 -pthread      -DLINUX -D_REENTRANT -D_GNU_SOURCE     -I. -I/root/httpd-2.4.23/os/unix -I/                                        root/httpd-2.4.23/include -I/usr/local/apr/include/apr-1 -I/root/httpd-2.4.23/modules/aaa -I/root/httpd-2.4.23/modules/cache -I/root/httpd-2.4.23/modules/core -I/root/httpd-2.4.23/modules/database                                         -I/root/httpd-2.4.23/modules/filters -I/root/httpd-2.4.23/modules/ldap -I/root/httpd-2.4.23/modules/loggers -I/root/httpd-2.4.23/modules/lua -I/root/httpd-2.4.23/modules/proxy -I/root/httpd-2.4.23/                                        modules/session -I/root/httpd-2.4.23/modules/ssl -I/root/httpd-2.4.23/modules/test -I/root/httpd-2.4.23/server -I/root/httpd-2.4.23/modules/arch/unix -I/root/httpd-2.4.23/modules/dav/main -I/root/h                                        ttpd-2.4.23/modules/generators -I/root/httpd-2.4.23/modules/mappers -prefer-pic -c ssl_engine_init.c && touch ssl_engine_init.slo
ssl_engine_init.c: In function 'make_dh_params':
ssl_engine_init.c:61:7: error: dereferencing pointer to incomplete type
     dh->p = prime(NULL);
       ^
ssl_engine_init.c:62:18: error: dereferencing pointer to incomplete type
     BN_dec2bn(&dh->g, gen);
                  ^
ssl_engine_init.c:63:12: error: dereferencing pointer to incomplete type
     if (!dh->p || !dh->g) {
            ^
ssl_engine_init.c:63:22: error: dereferencing pointer to incomplete type
     if (!dh->p || !dh->g) {
                      ^
ssl_engine_init.c: In function 'ssl_init_ctx_protocol':
ssl_engine_init.c:519:13: warning: 'TLSv1_client_method' is deprecated (declared at /usr/local/openssl/include/openssl/ssl.h:1598) [-Wdeprecated-declarations]
             TLSv1_client_method() : /* proxy */
             ^
ssl_engine_init.c:520:13: warning: 'TLSv1_server_method' is deprecated (declared at /usr/local/openssl/include/openssl/ssl.h:1597) [-Wdeprecated-declarations]
             TLSv1_server_method();  /* server */
             ^
ssl_engine_init.c:525:13: warning: 'TLSv1_1_client_method' is deprecated (declared at /usr/local/openssl/include/openssl/ssl.h:1604) [-Wdeprecated-declarations]
             TLSv1_1_client_method() : /* proxy */
             ^
ssl_engine_init.c:526:13: warning: 'TLSv1_1_server_method' is deprecated (declared at /usr/local/openssl/include/openssl/ssl.h:1603) [-Wdeprecated-declarations]
             TLSv1_1_server_method();  /* server */
             ^
ssl_engine_init.c:530:13: warning: 'TLSv1_2_client_method' is deprecated (declared at /usr/local/openssl/include/openssl/ssl.h:1610) [-Wdeprecated-declarations]
             TLSv1_2_client_method() : /* proxy */
             ^
ssl_engine_init.c:531:13: warning: 'TLSv1_2_server_method' is deprecated (declared at /usr/local/openssl/include/openssl/ssl.h:1609) [-Wdeprecated-declarations]
             TLSv1_2_server_method();  /* server */
             ^
ssl_engine_init.c: In function 'ssl_init_ctx_session_cache':
ssl_engine_init.c:641:9: warning: passing argument 2 of 'SSL_CTX_sess_set_get_cb' from incompatible pointer type [enabled by default]
         SSL_CTX_sess_set_get_cb(ctx,    ssl_callback_GetSessionCacheEntry);
         ^
In file included from ssl_private.h:90:0,
                 from ssl_engine_init.c:29:
/usr/local/openssl/include/openssl/ssl.h:621:6: note: expected 'struct SSL_SESSION * (*)(struct ssl_st *, const unsigned char *, int,  int *)' but argument is of type 'struct SSL_SESSION * (*)(stru                                        ct SSL *, unsigned char *, int,  int *)'
 void SSL_CTX_sess_set_get_cb(SSL_CTX *ctx,
      ^
ssl_engine_init.c: In function 'use_certificate_chain':
ssl_engine_init.c:861:5: warning: implicit declaration of function 'BIO_s_file_internal' [-Wimplicit-function-declaration]
     if ((bio = BIO_new(BIO_s_file_internal())) == NULL)
     ^
ssl_engine_init.c:861:5: warning: passing argument 1 of 'BIO_new' makes pointer from integer without a cast [enabled by default]
In file included from /usr/local/openssl/include/openssl/ssl.h:48:0,
                 from ssl_private.h:90,
                 from ssl_engine_init.c:29:
/usr/local/openssl/include/openssl/bio.h:537:6: note: expected 'const struct BIO_METHOD *' but argument is of type 'int'
 BIO *BIO_new(const BIO_METHOD *type);
      ^
In file included from ssl_private.h:33:0,
                 from ssl_engine_init.c:29:
ssl_engine_init.c: In function 'ssl_init_server_certs':
ssl_engine_init.c:1203:42: error: dereferencing pointer to incomplete type
                      BN_num_bits(dhparams->p), vhost_id, certfile);
                                          ^
/root/httpd-2.4.23/include/http_log.h:367:65: note: in definition of macro 'ap_log_error__'
              ap_log_error_(file, line, mi, level, status, sr__, __VA_ARGS__);    \
                                                                 ^
ssl_engine_init.c:1201:9: note: in expansion of macro 'ap_log_error'
         ap_log_error(APLOG_MARK, APLOG_DEBUG, 0, s, APLOGNO(02540)
         ^
make[3]: *** [ssl_engine_init.slo] Error 1
make[3]: Leaving directory `/root/httpd-2.4.23/modules/ssl'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/root/httpd-2.4.23/modules/ssl'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/root/httpd-2.4.23/modules'
make: *** [install-recursive] Error 1
Comment 1 Eric Covener 2017-06-06 11:08:50 UTC
openssl 1.1 isn't supported by any released level. 2.4.26 is under development and will support 1.1.