Bug 61292 - Report generator crashes with apdex_per_transaction parameter - Consumer failed
Summary: Report generator crashes with apdex_per_transaction parameter - Consumer failed
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.2
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-13 10:43 UTC by Sebastian Wilhelm
Modified: 2017-07-16 12:54 UTC (History)
0 users



Attachments
Logfile from the JMeter test run on the PetClinic application (24.15 KB, text/html)
2017-07-13 10:43 UTC, Sebastian Wilhelm
Details
Check for null samplerName (960 bytes, patch)
2017-07-16 12:36 UTC, Felix Schumacher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Wilhelm 2017-07-13 10:43:56 UTC
Created attachment 35127 [details]
Logfile from the JMeter test run on the PetClinic application

We try to generate an HTML report with the apdex_per_transaction parameter:

D:\apache-jmeter-3.2\bin\jmeter.bat -g D:\LoadTest_Results.wrt -o D:\TestReport -Jjmeter.reportgenerator.
apdex_per_transaction="0010(.*):1000|2000;"

But the report can't be created due to this error message:

An error occurred: Error while processing samples:Consumer failed with message :Consumer failed with message :Consumer 
failed with message :Consumer failed with message :null
errorlevel=1

Please find attached the logfile from the JMeter test run on the PetClinic application.
Comment 1 Felix Schumacher 2017-07-16 12:36:19 UTC
Created attachment 35144 [details]
Check for null samplerName

Check if samplerName is null, before comparing it with a regex.
Comment 2 Felix Schumacher 2017-07-16 12:54:46 UTC
Fixed in the upcoming JMeter 3.3 version.

Thanks for the report and the reproducible test case.