Bug 61319 - jmeter 3.2 Smtp smapler The same script Different in different versions running state, jmeter 3.2 false, jmeter 3.1 true, why? Can someone answer that?
Summary: jmeter 3.2 Smtp smapler The same script Different in different versions runni...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.2
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-20 02:30 UTC by Mr-Bear
Modified: 2017-07-20 17:30 UTC (History)
0 users



Attachments
Sampler-500 false (69.72 KB, image/jpeg)
2017-07-20 02:30 UTC, Mr-Bear
Details
smtpler false (27.64 KB, image/jpeg)
2017-07-20 02:31 UTC, Mr-Bear
Details
SMTP Sampler test.jmx (5.65 KB, application/xml)
2017-07-20 10:18 UTC, Mr-Bear
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mr-Bear 2017-07-20 02:30:30 UTC
Created attachment 35153 [details]
Sampler-500 false
Comment 1 Mr-Bear 2017-07-20 02:31:40 UTC
Created attachment 35154 [details]
smtpler false
Comment 2 Felix Schumacher 2017-07-20 10:04:30 UTC
Are there any exceptions in the jmeter.log file?

It's probably best to discuss problems with unknown causes on the users mailing list first.
Comment 3 Mr-Bear 2017-07-20 10:14:16 UTC
(In reply to Felix Schumacher from comment #2)
> jmeter.log文件中是否有异常?
> 
> 最好先在用户邮件列表上讨论未知原因的问题。

This is log:2017-07-20 18:11:47,698 INFO o.a.j.e.StandardJMeterEngine: Running the test!
2017-07-20 18:11:47,700 INFO o.a.j.s.SampleEvent: List of sample_variables: []
2017-07-20 18:11:47,700 INFO o.a.j.s.SampleEvent: List of sample_variables: []
2017-07-20 18:11:47,706 INFO o.a.j.g.u.JMeterMenuBar: setRunning(true, *local*)
2017-07-20 18:11:47,963 INFO o.a.j.e.StandardJMeterEngine: Starting ThreadGroup: 1 : 线程组
2017-07-20 18:11:47,963 INFO o.a.j.e.StandardJMeterEngine: Starting 1 threads for group 线程组.
2017-07-20 18:11:47,963 INFO o.a.j.e.StandardJMeterEngine: Thread will continue on error
2017-07-20 18:11:47,963 INFO o.a.j.t.ThreadGroup: Starting thread group... number=1 threads=1 ramp-up=1 perThread=1000.0 delayedStart=false
2017-07-20 18:11:47,968 INFO o.a.j.t.ThreadGroup: Started thread group number 1
2017-07-20 18:11:47,968 INFO o.a.j.e.StandardJMeterEngine: All thread groups have been started
2017-07-20 18:11:47,985 INFO o.a.j.t.JMeterThread: Thread started: 线程组 1-1
2017-07-20 18:11:48,059 INFO o.a.j.p.s.s.p.SendMailCommand: Use ssl/tls protocols for mail: SSLv2Hello SSLv3 TLSv1 TLSv1.1 TLSv1.2
2017-07-20 18:11:48,723 WARN o.a.j.p.s.s.SmtpSampler: 
javax.mail.MessagingException: IOException while sending message
	at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:1167) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	at org.apache.jmeter.protocol.smtp.sampler.protocol.SendMailCommand.execute(SendMailCommand.java:303) ~[ApacheJMeter_mail.jar:3.2 r1790748]
	at org.apache.jmeter.protocol.smtp.sampler.SmtpSampler.executeMessage(SmtpSampler.java:169) [ApacheJMeter_mail.jar:3.2 r1790748]
	at org.apache.jmeter.protocol.smtp.sampler.SmtpSampler.sample(SmtpSampler.java:146) [ApacheJMeter_mail.jar:3.2 r1790748]
	at org.apache.jmeter.threads.JMeterThread.executeSamplePackage(JMeterThread.java:491) [ApacheJMeter_core.jar:3.2 r1790748]
	at org.apache.jmeter.threads.JMeterThread.processSampler(JMeterThread.java:425) [ApacheJMeter_core.jar:3.2 r1790748]
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:254) [ApacheJMeter_core.jar:3.2 r1790748]
	at java.lang.Thread.run(Unknown Source) [?:1.8.0_131]
Caused by: java.io.FileNotFoundException: C:\Users\lenovo\Desktop (拒绝访问。)
	at java.io.FileInputStream.open0(Native Method) ~[?:1.8.0_131]
	at java.io.FileInputStream.open(Unknown Source) ~[?:1.8.0_131]
	at java.io.FileInputStream.<init>(Unknown Source) ~[?:1.8.0_131]
	at javax.activation.FileDataSource.getInputStream(Unknown Source) ~[?:1.8.0_131]
	at javax.activation.DataHandler.writeTo(Unknown Source) ~[?:1.8.0_131]
	at javax.mail.internet.MimeBodyPart.writeTo(MimeBodyPart.java:1574) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	at javax.mail.internet.MimeBodyPart.writeTo(MimeBodyPart.java:948) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	at javax.mail.internet.MimeMultipart.writeTo(MimeMultipart.java:538) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	at com.sun.mail.handlers.multipart_mixed.writeTo(multipart_mixed.java:103) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	at javax.activation.ObjectDataContentHandler.writeTo(Unknown Source) ~[?:1.8.0_131]
	at javax.activation.DataHandler.writeTo(Unknown Source) ~[?:1.8.0_131]
	at javax.mail.internet.MimeBodyPart.writeTo(MimeBodyPart.java:1574) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	at javax.mail.internet.MimeMessage.writeTo(MimeMessage.java:1840) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:1119) ~[mail-1.5.0-b01.jar:1.5.0-b01]
	... 7 more
2017-07-20 18:11:48,743 INFO o.a.j.t.JMeterThread: Thread is done: 线程组 1-1
2017-07-20 18:11:48,743 INFO o.a.j.t.JMeterThread: Thread finished: 线程组 1-1
2017-07-20 18:11:48,744 INFO o.a.j.e.StandardJMeterEngine: Notifying test listeners of end of test
2017-07-20 18:11:48,745 INFO o.a.j.g.u.JMeterMenuBar: setRunning(false, *local*)
Comment 4 Mr-Bear 2017-07-20 10:18:01 UTC
Created attachment 35155 [details]
SMTP Sampler test.jmx

SMTP Sampler test.jmx
Comment 5 Mr-Bear 2017-07-20 10:18:35 UTC
I uploaded the script.   "SMTP Sampler test.jmx"
Comment 6 Felix Schumacher 2017-07-20 17:30:15 UTC
Thanks for the report (especially the jmeter.log).

The bug will be fixed in JMeter v3.3. It would be nice, if you could test the next nightly and report back, if it fixes your problem.

Date: Thu Jul 20 17:28:59 2017
New Revision: 1802515

URL: http://svn.apache.org/viewvc?rev=1802515&view=rev
Log:
Fix regression: SMTP Sampler could not send mails, when no attachements where specified.

Bugzilla Id: 61319

Modified:
    jmeter/trunk/src/protocol/mail/org/apache/jmeter/protocol/smtp/sampler/SmtpSampler.java
    jmeter/trunk/xdocs/changes.xml