Bug 61494 - Updating meta properties in xlsm/xlsx corrupted equation
Summary: Updating meta properties in xlsm/xlsx corrupted equation
Status: RESOLVED DUPLICATE of bug 59268
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.16-FINAL
Hardware: PC Linux
: P2 critical (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on: 54084 59268
Blocks:
  Show dependency tree
 
Reported: 2017-09-06 11:32 UTC by azad
Modified: 2017-09-22 05:17 UTC (History)
1 user (show)



Attachments
Actual Content (12.33 KB, image/jpeg)
2017-09-06 11:33 UTC, azad
Details
Corrupted Content (11.23 KB, image/jpeg)
2017-09-06 11:34 UTC, azad
Details
Source and example files (15.87 KB, application/zip)
2017-09-20 06:47 UTC, azad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description azad 2017-09-06 11:32:31 UTC
If any Core or Custom property added to the xlsx or xlsm file, It will corrupt part of the content (to ? replacing actual value) in the floating equation textbox.

Please follow the attachment, 
- right.jpg is the actual content
- wrong.jpg is the corrupted one
Comment 1 azad 2017-09-06 11:33:31 UTC
Created attachment 35299 [details]
Actual Content
Comment 2 azad 2017-09-06 11:34:02 UTC
Created attachment 35301 [details]
Corrupted Content
Comment 3 Dominik Stadler 2017-09-19 20:19:55 UTC
Can you provide unit-tests/sample-code/sample-files which allows to reproduce the problem? Without this it is not possible to see where the actual problem is.
Comment 4 azad 2017-09-20 06:47:53 UTC
Created attachment 35339 [details]
Source and example files
Comment 5 azad 2017-09-20 06:50:31 UTC
Hi Dominik,
Thanks for your concern.

I have attached those source and input/output files in a zip as attachment here.

Please feel free to ask any question!

-a-
Comment 6 azad 2017-09-21 11:23:09 UTC
Hi Dominik,
I was just wondering if you could use the source code and reproduce the broken output file?

Thanks again!
-a-
Comment 7 Dominik Stadler 2017-09-21 16:10:10 UTC
FYI, for me this also happens when not adding any property at all, just reading and writing the XLSX suffices. Very likely this is a duplicate of bug 54084, which itself depends on a fix in the XMLBeans library, see bug 59268 all the details.

There is an updated test-version of the XMLBeans library available at http://mvnrepository.com/artifact/com.github.pjfanning/xmlbeans/2.6.2, using this one makes this work for me, independent of writing custom/core properties or not. So you might be able to use this library instead of xmlbeans-2.6.0.jar.

So this bug is a duplicate and will be fixed when we can get an updated version of XMLBeans made available officially.

*** This bug has been marked as a duplicate of bug 59268 ***
Comment 8 azad 2017-09-22 05:17:59 UTC
Thanks, it works with xmlbeans-2.6.2