Bug 61526 - '#' is not recognized as an internal or external command,operable program or batch file.
Summary: '#' is not recognized as an internal or external command,operable program or ...
Status: RESOLVED DUPLICATE of bug 61419
Alias: None
Product: Tomcat 9
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 9.0.0.M26
Hardware: PC All
: P2 enhancement (vote)
Target Milestone: -----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-16 00:08 UTC by jambo.wang
Modified: 2017-09-16 01:17 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jambo.wang 2017-09-16 00:08:00 UTC
Startup.bat give an error message as below:
'#' is not recognized as an internal or external command,operable program or batch file.

Read the codes and found the problem caused by line 218 in catalina.bat:
    # Configure JAVA 9 specific start-up parameters

This line suppose to be a comment line, change the "#" to "rem" then the error message disappear.
Comment 1 Igal Sapir 2017-09-16 00:24:16 UTC
This has already been fixed at https://github.com/apache/tomcat/commit/3fed0a2
Comment 2 Chuck Caldarale 2017-09-16 01:17:31 UTC

*** This bug has been marked as a duplicate of bug 61419 ***