Bug 61547 - Custom Properties for a XLSX file are not being saved when using OPCPackage
Summary: Custom Properties for a XLSX file are not being saved when using OPCPackage
Status: RESOLVED DUPLICATE of bug 51971
Alias: None
Product: POI
Classification: Unclassified
Component: OPC (show other bugs)
Version: 3.17-FINAL
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-20 12:17 UTC by oracle15
Modified: 2017-12-30 23:39 UTC (History)
0 users



Attachments
File for bug replication (1.61 KB, text/plain)
2017-09-20 12:17 UTC, oracle15
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oracle15 2017-09-20 12:17:26 UTC
Created attachment 35341 [details]
File for bug replication

I wanted to encrypt an XLSX file with a password while adding some Core Properties and Custom Properties to it.

To accomplish that I'm using an OPCPackage object and modifying its Properties.
After saving the file, only the Core Properties appear.

I attached the java file I used to replicate this issue.

From what I could investigate, the issue may be related with the save method from OPCPackage which is not saving the Custom Properties.
Comment 1 Dominik Stadler 2017-12-30 15:32:43 UTC
I reproduced this using LibreOffice both with and without encryption, so I think this is similar to bug 51971, where a patch was proposed a while ago, but did not make it into the code. 

You can help this issue by reviewing and updating the patch to work on the latest code-base.

*** This bug has been marked as a duplicate of bug 51971 ***
Comment 2 Sérgio Teixeira 2017-12-30 23:39:48 UTC
I've made the fix for the 51971. In case you have questions send them through. I'll try to remember what I did for that fix attempt.

Regards